I have just installed Linux Mint 14 and I cannot change the screen resolution. The appropriate resolution 1920 x 1200, just isn't among the options.

I have tried this solution but it reports:

xrandr: cannot find output "VGA1"

I have also tried this, but it reports:

Fatal server error:
Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 


My graphics card information:

Graphics:  Card: NVIDIA GF108 [GeForce GT 440] bus-ID: 01:00.0 X.Org: 1.13.0 driver: nvidia Resolution: [email protected] 
           GLX Renderer: GeForce GT 440/PCIe/SSE2 GLX Version: 4.3.0 NVIDIA 313.26 Direct Rendering: Yes

Running sudo lshw -class outputs:

       description: VGA compatible controller
       product: GF108 [GeForce GT 440]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:fa000000-faffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:fb000000-fb07ffff
       description: Display controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list
       configuration: driver=i915 latency=0
       resources: irq:57 memory:fb400000-fb7fffff memory:b0000000-bfffffff ioport:f000(size=64)


Running xrandr command in terminal outputs:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-3 disconnected (normal left inverted right x axis y axis)
VGA-2 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  

This is without nvidia driver installed.


After executing command xrandr --newmode "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync it reports:

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  29
  Current serial number in output stream:  29


When I try solution from here running sudo Xorg -configure, I get:

Fatal server error:
Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.

Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
  • What is your output from xrandr without options? Are you using the correct output name?
    – Dave C
    Commented Mar 12, 2013 at 19:41
  • @DaveC Unfortunately I had to reinstall Linux Mint because I probably did somthing wrong in trying this solution uk.answers.yahoo.com/question/index?qid=20100328145624AAA7lYQ. For your question please see second update.
    – eomeroff
    Commented Mar 12, 2013 at 20:45
  • The output is VGA-2 it looks like, hence why VGA0 wasn't found. Try your xrandr command but using --ouput VGA-2
    – Dave C
    Commented Mar 12, 2013 at 20:50
  • @DaveC It this exact command: xrandr --output VGA-2 ? Because nothing happens when execute this.
    – eomeroff
    Commented Mar 12, 2013 at 21:40
  • Have you tried nvidia-settings (I assume you do use NVIDIA driver, do you?)?
    – poige
    Commented Mar 16, 2013 at 17:38

5 Answers 5


Based on your xrandr output above there are two problems; firstly the output name is VGA-2 (not VGA0) and secondly it seems that you don't have a mode available for 1920x1200.

First just try setting the resolution:

xrandr --output VGA-2 --size 1920x1200

If that doesn't work (which I think it won't as 1920x1200 isn't a mode) then do the following:

cvt 1920 1200

Copy and paste the full modeline information e.g. for me I get:

Modeline "1920x1200_60.00"  193.25  1920 2056 2256 2592  1200 1203 1209 1245 -hsync +vsync

What we want to copy is what is after Modeline e.g. "1920x1200_60.00" 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync

Now do the following:

xrandr --addmode VGA-2 1920x1200_60.00

e.g. in the second command after the VGA-2 we put the bit in quotes from modeline


xrandr --output VGA-2 --mode 1920x1200_60.00

The same descriptor for the mode.

This should create a new mode of 1920x1200, assign that mode for VGA-2 and then set VGA-2 to use that mode.

  • Please see Edit3
    – eomeroff
    Commented Mar 12, 2013 at 22:29
  • What did the xrandr --output VGA-1 --size 1920x1200 do? Anything, and try it without the output: xrandr --size 1920x1200.
    – Dave C
    Commented Mar 12, 2013 at 22:34
  • $ xrandr --output VGA-1 --size 1920x1200 outputs: warning: output VGA-1 not found; ignoring and $ xrandr --size 1920x1200 outputs: Size 1920x1200 not found in available modes
    – eomeroff
    Commented Mar 12, 2013 at 22:36
  • Try the same set of commands in my answer but with: cvt 1920 1200 59.90
    – Dave C
    Commented Mar 12, 2013 at 22:37
  • Oh and of course then using 1920x1200_59.90 in place of 1920x1200_60.00
    – Dave C
    Commented Mar 12, 2013 at 22:37

Why dont you try setting the resolution using a graphical frontend for xrandr such as:




Try to stop your XServer before dongin Xorg -configure.

  1. Log-out of all accounts.
  2. Press Ctrl+Alt+F1
  3. Log-in with your regular account (take care if yo use number with num lock - try with your login to see)
  4. Run sudo service mdm stop
  5. Run nvidia-settings if you have this one or Xorg -configure
  6. Run sudo service mdm start
  7. If you're still on terminal, press Ctrl+Alt+F7 and log-in

You want to use nvidia-settings if it isn't installed yet install it. It will access the proprietary nvidia drivers directly and you should be able to configure them. If that doesn't work try the answer here: http://community.linuxmint.com/tutorial/view/176

Sorry if you wanted a terminal-based answer; I'm not that hard-core.


What worked for me was a similar approach to Dave C's. My monitor wasn't being identified so the driver would only give me the standard resolutions.

First, look up the horizontal and vertical refresh rates for your monitor. If they aren't in the manual that came with the monitor (or the manual is no longer handy) you can probably get them from the manufacturer's Web site. Add that info to /etc/X11/xorg.conf.d/50-monitor.conf .

Use those refresh rates with cvt to calculate the mode lines and add them to the 50-monitor.conf file. The result should look something like this:

Section "Monitor"
  Identifier "Monitor0"
  VendorName "Samsung"
  ModelName "Samsung S27C230"
  HorizSync 30-81
  VertRefresh 56-75
  # 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
  Modeline "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Now add the mode to 50-screen.conf in the same directory:

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes "1920x1080" 

You could do all of this in /etc/X11/xorg.conf, but the Xorg server prefers these smaller files. If you haven't already, copy the Device section from the xorg.conf file into xorg.conf.d/50-device.conf and rename xorg.conf to avoid conflicts. Now, when you restart your X server (reboot) the new mode will be available.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .