9

I do dual boot Kali-Linux with Windows11. So the problem is I want to connect with my Bluetooth speaker (JBL GO), but unfortunately I cannot connect. I use both GUI and CLI to connect to my speaker. It was working perfectly before. I can connect in Windows, but not in my Kali.

Here is the message using GUI: GUI

And here is the message using CLI:

$ bluetoothctl                                                                                  
Agent registered
[bluetooth]# agent KeyboardOnly
Agent is already registered
[bluetooth]# default-agent 
Default agent request successful
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:1A:7D:DA:71:15 Discovering: yes
[CHG] Device 30:C0:1B:95:1D:C3 RSSI: -51
[CHG] Device 30:C0:1B:95:1D:C3 TxPower: 0
[bluetooth]# remove 30:C0:1B:95:1D:C3
[DEL] Device 30:C0:1B:95:1D:C3 JBL GO
Device has been removed
[NEW] Device 30:C0:1B:95:1D:C3 JBL GO
[CHG] Device 30:C0:1B:95:1D:C3 TxPower: 0
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000110d-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[bluetooth]# trust 30:C0:1B:95:1D:C3
[CHG] Device 30:C0:1B:95:1D:C3 Trusted: yes
Changing 30:C0:1B:95:1D:C3 trust succeeded
[bluetooth]# pair 30:C0:1B:95:1D:C3
Attempting to pair with 30:C0:1B:95:1D:C3
[CHG] Device 30:C0:1B:95:1D:C3 Connected: yes
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 00001101-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 00001108-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000110b-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 UUIDs: 0000111e-0000-1000-8000-00805f9b34fb
[CHG] Device 30:C0:1B:95:1D:C3 ServicesResolved: yes
[CHG] Device 30:C0:1B:95:1D:C3 Paired: yes
Pairing successful
[CHG] Device 30:C0:1B:95:1D:C3 ServicesResolved: no
[CHG] Device 30:C0:1B:95:1D:C3 Connected: no
[bluetooth]# connect 30:C0:1B:95:1D:C3
Attempting to connect to 30:C0:1B:95:1D:C3
Failed to connect: org.bluez.Error.Failed
[bluetooth]# exit

I check the bluetooth.service:

$ sudo systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: disabled)
     Active: active (running) since Sat 2021-11-06 08:32:21 WIB; 47min ago
       Docs: man:bluetoothd(8)
   Main PID: 3844 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 38347)
     Memory: 2.0M
        CPU: 439ms
     CGroup: /system.slice/bluetooth.service
             └─3844 /usr/libexec/bluetooth/bluetoothd

Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSink/sbc
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSource/sbc
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSink/sbc_xq_453
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSource/sbc_xq_453
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSink/sbc_xq_512
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSource/sbc_xq_512
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSink/sbc_xq_552
Nov 06 09:12:21 [hostname] bluetoothd[3844]: Endpoint registered: sender=:1.87 path=/MediaEndpoint/A2DPSource/sbc_xq_552
Nov 06 09:12:30 [hostname] bluetoothd[3844]: /org/bluez/hci0/dev_30_C0_1B_95_1D_C3/sep1/fd0: fd(42) ready
Nov 06 09:12:30 [hostname] bluetoothd[3844]: profiles/audio/avctp.c:avctp_connect_browsing_cb() Browsing: connect to 30:C0:1B:95:1D:C3: Connection refused (111)

I already try rfkill, alsa but no result. But when I try these command:

$ pulseaudio -k
$ pulseaudio -D
$ pulseaudio --start

, it works. But I cannot find my device in pavucontrol. Now I'm stuck :| GUI Connected

Here is my version of Kali:

$ uname -a
Linux [my_hostname] 5.14.0-kali2-amd64 #1 SMP Debian 5.14.9-2kali1 (2021-10-04) x86_64 GNU/Linux

Bluetoothctl version: bluetoothctl: 5.61

Blueman version: 2.2.2-1

2 Answers 2

12

I have been beating my head about this issue. I have been encountering it for a few days since the latest round of apt updates available for Kali. After doing some digging I discovered that there are some package changes associated with PipeWire and pulseaudio components (specifically the removal of pipewire-media-session, the new installation of pipewire-pulse, and an upgrade to pipewire)

I found the following article: https://wiki.debian.org/BluetoothUser/a2dp#PipeWire

"At minimum, you will need to install the libspa-0.2-bluetooth package, remove the pulseaudio-module-bluetooth package (if previously installed), and then either reboot your computer or restart the PipeWire services, otherwise device connections will fail with "Protocol not available".

apt install libspa-0.2-bluetooth && apt purge pulseaudio-module-bluetooth

reboot

I now have audio endpoints and I can still configure with pavucontrol.

This was a very simple fix to a very ugly issue that surfaced out of nowhere. I hope this may help someone out there still facing this.

ADDITIONAL

I found that adding the load-module functions to /etc/pulse/default.pa described in the other resolution response from @sup2069 seems to have corrected an issue I was having where it would not remember my audio profiles. I would have to reconfigure the default audio source in pavucontrol every time the device reconnects. I just wanted to throw that bit of information out there. Thank you folks for all of your contributions to this community!

3
  • 3
    Wow, this tutorial solve the issue permanently. Thank you so much. :D Nov 10, 2021 at 4:39
  • Thank you for starting the thread literally as soon as the issue surfaced. I was certain that a web search would yield outdated methods, as this was certainly caused by a very recent "unclean" upgrade of the sound server backend. I have found that using PipeWire has much less latency, especially with the new "Pro Audio" option that allows me to configure my external mixing consoles without having to completely disable pulseaudio to avoid latency.
    – TechInMD
    Nov 10, 2021 at 11:16
  • god bless you bro Dec 25, 2021 at 17:09
4

I had the same issue as you and my search led me here. Did more digging around and I solved my issue on my Debian Sid build.

Added the following to /etc/pulse/default.pa or /etc/pulse/default.pa.d/bluez5.pa. I created and inserted mine into bluez5.pa.

load-module module-bluez5-device
load-module module-bluez5-discover

Save and exit.

I rebooted (may not need to) then ran the following commands to have pulse audio load on start (the endpoint errors were caused because it had no audio to bind to; until you manually started it with pulseaudio -D and pulsaudio --start).

Next, run these commands to have pulseaudio load on user login, but do not run it with privileged access or you may encounter errors.

systemctl --user enable pulseaudio
systemctl --user start pulseaudio

Then I removed my bluetooth headset and re-paired. They connected and also showed up in the mixer panel. You can also go further and power off the bluetooth device then back on, pair again.

Note: Due to my rep, I was unable to ask questions in the comments to gather more info from you.

3
  • It works for me. Thank you! :D Nov 8, 2021 at 0:14
  • You're welcome. If the problem returns during reboots (updating broke it), you can toss the "systemctl" enable/start portion along with "pulseaudio --start" into a script to fix the problem without rebooting.
    – sup2069
    Nov 12, 2021 at 1:45
  • working on Debian Bookworm...
    – Mario
    Nov 15, 2021 at 8:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.