5

I upgraded to Fedora 35 two days ago. At first, everything seemed to be working fine. But suddenly I had sound (and video) problems. Video was playing every 20 seconds one frame, audio not at all. After restarting everything seemed to be fine.

But at some point, not even rebooting solved the issue. So I tried systemctl --user enable --now wireplumber.

This solved the issue at first but not for long. Anyway, I did a lot of different things, like: sudo dnf swap wireplumber pipewire-media-session or installing pipewire-pulse and running it.

Currently it looks like this: pactl list short sinks returns this (I need 45, but the numbers keep changing):

35  alsa_output.pci-0000_0b_00.1.hdmi-stereo    PipeWire    s16le 2ch 48000Hz   SUSPENDED
45  alsa_output.usb-Focusrite_Scarlett_6i6_USB_00052950-00.analog-surround-21   PipeWire    s32le 3ch 48000Hz   SUSPENDED
47  alsa_output.pci-0000_0d_00.3.iec958-stereo  PipeWire    s16le 2ch 48000Hz   SUSPENDED

Number 35 works when selecting it with pactl set-default-sink 35, but 45 does not. And furthermore, my audio interface, a Focusrite Scarlett 6i6, doesn't even register mic input (it normally does, I can see the input light lighting up when I talk on the interface, even when connected to no computer at all).

It seems to be something wrong with it, but in Windows everything is still okay, and a with Fedora 34 and even a yesterday it worked fine with Fedora 35 for some time.

I have no idea what low level media server I have installed now, what I changed and what I didn't change, so I'm glad to provide further details.

I would love to go back to the audio setup with Fedora 34, but I'm unable to make a clean uninstall of all current audio drivers or media servers etc and I don't even know how Fedora 34 worked with audio. Even after reading the arch linux wiki entry for pulseaudio, alsamixer, pact and pipewire I still have no idea on how they are related and what they do.

1 Answer 1

3

For me running sudo dnf swap --allowerasing pulseaudio pipewire-pulseaudio as suggested at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=2016253 worked.

After a reboot sound was working as usual.

1
  • 1
    Just wanted to let you know that your answer probably saved my sanity, and my academic career. Thank you sir.
    – Noumeno
    Jan 22 at 11:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.