0

With Linux Debian Buster, I set a password for GRUB2 (version 2.02) but I can not use entirely the numpad keys for typing the user nor the password. When I press 0 (zero) from the numpad I obtain Unknown key 0x62 but the other numpad keys work.

I observed the same from GRUB shell (from Grub menu press C key to switch to command line) I can press other numpad keys without error. Only the zero numpad key triggers this message...

What is wrong ?


I just realized that the probable cause for this problem is the creation of the /boot/grub/layouts/fr.gkb file.

At the same time that protect GRUB with password I wanted to make the GRUB shell more convenient to use with an AZERTY keyboard (I'm French).

So following this guide I created this file with this command (I translated the returned french messages in english) :

root@host:~# ckbcomp fr | grub-mklayout -o /boot/grub/layouts/fr.gkb
Unknown Meta_Tab key identifier
Unknown Meta_Tab key identifier
Unknown key code 0x54
Unknown key code 0x65
Unknown key code 0x7f

The command succeeds but returns messages that some key codes are unknown (messages that I ignored by telling myself that it must be normal).

It looks strangely like the problem observed, even if the 0x62 code reported by GRUB (see above) is not part of it but must be related.

To be convinced, I removed the French GRUB support and from the GRUB shell I tested the following numpad keys :

0123456789/*-+

Who gives no error this time.

So the problem comes from the creation of fr.gkb but I have no idea how to solve the problem.


I discovered that ckbcomp fr displays an organised flow that I do not know how to decrypt but which seems OK (no error) and ckbcomp fr read in fact the keyboard file /usr/share/X11/xkb/symbols/fr but I do not know how to modify this file which seems more accessible to me that the ckbcomp flow.

3
  • On my machine, I can select NUMPAD ON in the BIOS.
    – Stewart
    Nov 4, 2021 at 7:46
  • In my case nothing to do with BIOS it is enabled because I can press other numpad keys without error. I suspect a bug and I isolated the problem in typing 123456789/*-+0 from GRUB shell (from Grub menu press C key to switch to command line). Only the 0 (zero) numpad key triggers this message... Nov 4, 2021 at 18:19
  • Nobody to help me ? Nov 7, 2021 at 17:53

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.