2

I've read When does "apt-get install" ask me to confirm whether I want to continue or not? (year 2013):

prompt appears when:

  • Extra packages (besides those you asked to install - e.g. dependencies) will be installed
  • Essential packages are to be removed. Essential here is defined as the minimal set of functionality that must be available and usable on the system at all times, even when packages are in an unconfigured (but unpacked) state. Packages are tagged essential for a system using the Essential control field.
  • Changing a held package

However, on my Linux Mint 20.2 now I noticed that apt / apt-get displayed confirmation for removal of non-essential package and installation of package which was supplied on command line. What is the current requirements for apt confirmations now in 2021 as opposed to 2013?

$ sudo apt remove python-docutils
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  python-docutils
0 upgraded, 0 newly installed, 1 to remove and 636 not upgraded.
After this operation, 1 814 kB disk space will be freed.
Do you want to continue? [Y/n] y

$ apt show python-docutils
Package: python-docutils
Version: 0.16+dfsg-2
Priority: optional
Section: universe/python
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 1 814 kB
Provides: docutils
Depends: docutils-common (= 0.16+dfsg-2), python-roman, python2:any (<< 2.8), python2:any (>= 2.7~)
Recommends: docutils-doc (= 0.16+dfsg-2), libpaper-utils, python-pil, python-pygments
Suggests: fonts-linuxlibertine | ttf-linux-libertine, texlive-lang-french, texlive-latex-base, texlive-latex-recommended
Homepage: https://docutils.sourceforge.io/
Download-Size: 369 kB
APT-Manual-Installed: yes
# ------------ as apposed to e.g. grep:
$ apt show grep
Package: grep
Version: 3.4-1
Priority: required
Essential: yes



$ sudo apt-get install /media/alex/usb/LM_20.2/python-docutils/*.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'docutils-common' instead of '/media/alex/usb/LM_20.2/python-docutils/docutils-common_0.16+dfsg-2_all.deb'
Note, selecting 'docutils-doc' instead of '/media/alex/usb/LM_20.2/python-docutils/docutils-doc_0.16+dfsg-2_all.deb'
Note, selecting 'libpython2.7-minimal' instead of '/media/alex/usb/LM_20.2/python-docutils/libpython2.7-minimal_2.7.18-1~20.04.1_amd64.deb'
Note, selecting 'libpython2.7-stdlib' instead of '/media/alex/usb/LM_20.2/python-docutils/libpython2.7-stdlib_2.7.18-1~20.04.1_amd64.deb'
Note, selecting 'libpython2-stdlib' instead of '/media/alex/usb/LM_20.2/python-docutils/libpython2-stdlib_2.7.17-2ubuntu4_amd64.deb'
Note, selecting 'python2' instead of '/media/alex/usb/LM_20.2/python-docutils/python2_2.7.17-2ubuntu4_amd64.deb'
Note, selecting 'python2.7' instead of '/media/alex/usb/LM_20.2/python-docutils/python2.7_2.7.18-1~20.04.1_amd64.deb'
Note, selecting 'python2.7-minimal' instead of '/media/alex/usb/LM_20.2/python-docutils/python2.7-minimal_2.7.18-1~20.04.1_amd64.deb'
Note, selecting 'python2-minimal' instead of '/media/alex/usb/LM_20.2/python-docutils/python2-minimal_2.7.17-2ubuntu4_amd64.deb'
Note, selecting 'python-chardet' instead of '/media/alex/usb/LM_20.2/python-docutils/python-chardet_3.0.4-4build1_all.deb'
Note, selecting 'python-docutils' instead of '/media/alex/usb/LM_20.2/python-docutils/python-docutils_0.16+dfsg-2_all.deb'
Note, selecting 'python-olefile' instead of '/media/alex/usb/LM_20.2/python-docutils/python-olefile_0.46-2_all.deb'
Note, selecting 'python-pil' instead of '/media/alex/usb/LM_20.2/python-docutils/python-pil_6.2.1-3_amd64.deb'
Note, selecting 'python-pkg-resources' instead of '/media/alex/usb/LM_20.2/python-docutils/python-pkg-resources_44.0.0-2_all.deb'
Note, selecting 'python-pygments' instead of '/media/alex/usb/LM_20.2/python-docutils/python-pygments_2.3.1+dfsg-1ubuntu2.2_all.deb'
Note, selecting 'python-roman' instead of '/media/alex/usb/LM_20.2/python-docutils/python-roman_2.0.0-3build1_all.deb'
docutils-common is already the newest version (0.16+dfsg-2).
docutils-doc is already the newest version (0.16+dfsg-2).
libpython2-stdlib is already the newest version (2.7.17-2ubuntu4).
python-chardet is already the newest version (3.0.4-4build1).
python-olefile is already the newest version (0.46-2).
python-pil is already the newest version (6.2.1-3).
python-pkg-resources is already the newest version (44.0.0-2).
python-roman is already the newest version (2.0.0-3build1).
python2 is already the newest version (2.7.17-2ubuntu4).
python2-minimal is already the newest version (2.7.17-2ubuntu4).
libpython2.7-minimal is already the newest version (2.7.18-1~20.04.1).
libpython2.7-stdlib is already the newest version (2.7.18-1~20.04.1).
python-pygments is already the newest version (2.3.1+dfsg-1ubuntu2.2).
python2.7 is already the newest version (2.7.18-1~20.04.1).
python2.7-minimal is already the newest version (2.7.18-1~20.04.1).
Suggested packages:
  fonts-linuxlibertine | ttf-linux-libertine texlive-lang-french texlive-latex-base texlive-latex-recommended
The following NEW packages will be installed:
  python-docutils
0 upgraded, 1 newly installed, 0 to remove and 636 not upgraded.
Need to get 0 B/369 kB of archives.
After this operation, 1 814 kB of additional disk space will be used.
Do you want to continue? [Y/n] n

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.