3

I installed QEMU this way:

sudo apt-get install qemu-system-arm
sudo apt-get install qemu-efi-aarch64
sudo apt-get install qemu-utils
dd if=/dev/zero of=flash1.img bs=1M count=64
dd if=/dev/zero of=flash0.img bs=1M count=64
dd if=/usr/share/qemu-efi-aarch64/QEMU_EFI.fd of=flash0.img conv=notrunc
qemu-img create ubuntu-image.img 20G

then downloaded the debian-11.1.0-arm64-netinst.iso ISO file from this URL (now broken) and ran

qemu-system-aarch64 -nographic -machine virt,gic-version=max -m 3G -cpu max -smp 4 \
-netdev user,id=vnet,hostfwd=:127.0.0.1:0-:22 -device virtio-net-pci,netdev=vnet \
-drive file=ubuntu-image.img,if=none,id=drive0,cache=writeback -device virtio-blk,drive=drive0,bootindex=0 \
-drive file=debian-11.1.0-arm64-netinst.iso,if=none,id=drive1,cache=writeback -device virtio-blk,drive=drive1,bootindex=1 \
-drive file=flash0.img,format=raw,if=pflash -drive file=flash1.img,format=raw,if=pflash

The installer starts to run properly but then fails with following error:

        [!!] Detect and mount installation media

No device for installation media was detected.

You may need to load additional drivers from removable media, such as a driver floppy or a USB stick.  If you have these available now, insert the media, and continue.  Otherwise, you will be given the option to manually select some modules.

Load drivers from removable media?

  <Yes>                          <No>

  [Manually transcribed from this screen-shot image.]

Why? How do I install Debian on QEMU?

1 Answer 1

7

When using virtio-blk (i.e., paravirtualized hard disks), the associated devices that will be visible to the installer are /dev/vdX, instead of the more common /dev/sdX or /dev/hdX. My understanding is that the Debian 11 installer (at least the arm64 version) doesn't look for the installation media on those devices.

The good news is that you can fix that without leaving the installer, by answering its questions (no to "load driver" in your screenshot, yes to "specify another device" in the following one, and up to the dialog where you can specify to use /dev/vda).

Should /dev/vda not work, do Alt+F2 to activate another console and run blkid to get a better understanding of how the various drives are listed.

How do I know? I was fighting that same bug less than 24 hours ago...

I did report it as a bug to Debian – feel free to add to it as needed.

2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .