I'm trying to install Linux Mint 14.1 on my Lenovo B570, but when I try to boot the thumb drive, it displays a message: "Secure boot is not enabled" and then goes black screen. I read lots of posts on the subject, but there is one difference from other people's problems. I have Windows 7 installed (since over a year ago) and around 5 months ago I installed Kubuntu 12.10 without any problem (it was even the same flash drive). Now I'm facing the secure boot problem and I don't know what to do.


I have this same model laptop (Lenovo B570) and I resolved this issue by disabling/removing all BIOS passwords.


I'm not sure exactly what your problem is. But, when you boot next time, get into BIOS configuration and check up your "Secure boot" option. I'm guessing it is "disabled". If it is, then enable it. Reboot and see what will happens. If this doesn't help, then I will be here for you until it is done.


Can you check if your system has secure boot enabled? For that you need to check from BIOS/UEFI settings. I assume that "secure boot" should not be enabled on your system and I think it is expected.

If your system does not support secure boot then it is an issue with the "Installation Media". As far as the message is concerned, it is just a "warning" and nothing else but since you get a blank screen(which is a serious issue) so, I think its an issue with the OS itself. You can try different version of linux-mint.

FYI, such issue existed in Ubuntu also. Refer this link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.