0

Redmine has typically been something I have been struggling with when it comes to install/upgrade it, owing to the need to work with gems/gemfiles, something I'm not too familiar with.

I have had an old version of Redmine working smoothly on my debian LAMP server, however with the recent release of Debian 11 (Bullseye) I decided to finally upgrade my debian version. However I get into the error below where Bundler cannot find rails (~> 5.2.2). However I have updated all my gems and my bundler version is: rails (6.1.4.1, 6.0.3.7).

Looking at some reported issued on the internet I only find a few things mentioning similar (indentical?) issues, like this bug report:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=969206

however there is no indication on how can I solve this issue.

As such, any help would be very much appreciated. Thank you in advance.

Below I am appending the printouts of my apt install logs, and also the list of all my installed gems.

501.0 # apt install redmine
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
redmine is already the newest version (4.0.7-1).
0 upgraded, 0 newly installed, 0 to remove and 901 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
Setting up redmine (4.0.7-1) ...
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root users on this machine.
Could not find gem 'rails (~> 5.2.2)' in cached gems from rubygems repository https://rubygems.org/ or installed locally.
The source contains the following versions of 'rails': 6.0.3.7, 6.1.4.1
dpkg: error processing package redmine (--configure):
 installed redmine package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 redmine
E: Sub-process /usr/bin/dpkg returned an error code (1)
Installed GEMS

504.0 # gem list --local

*** LOCAL GEMS ***

actioncable (6.1.4.1, 6.0.3.7)
actionmailbox (6.1.4.1, 6.0.3.7)
actionmailer (6.1.4.1, 6.0.3.7)
actionpack (6.1.4.1, 6.0.3.7)
actionpack-action_caching (1.2.2, 1.2.1)
actionpack-xml_parser (2.0.1)
actiontext (6.1.4.1, 6.0.3.7)
actionview (6.1.4.1, 6.0.3.7)
activejob (6.1.4.1, 6.0.3.7)
activemodel (6.1.4.1, 6.0.3.7)
activerecord (6.1.4.1, 6.0.3.7)
activestorage (6.1.4.1, 6.0.3.7)
activesupport (6.1.4.1, 6.0.3.7)
addressable (2.8.0, 2.7.0)
arel (9.0.0)
atomic (1.1.101, 1.1.16)
awesome_nested_set (3.4.0, 3.0.0)
benchmark (0.1.1, default: 0.1.0)
bigdecimal (3.0.2, default: 2.0.0)
blankslate (3.1.3)
builder (3.2.4)
bundler (2.2.29, 2.2.5, default: 2.1.4)
cgi (0.2.0, default: 0.1.0)
coderay (1.1.3)
coffee-script (2.4.1)
coffee-script-source (1.12.2)
columnize (0.9.0)
concurrent-ruby (1.1.9, 1.1.6)
concurrent-ruby-edge (0.6.0)
connection_pool (2.2.5, 2.2.2)
crass (1.0.6, 1.0.2)
css_parser (1.10.0, 1.6.0)
csv (3.2.0, default: 3.1.2)
date (3.1.1, default: 3.0.0)
dbm (default: 1.1.0)
delegate (0.2.0, default: 0.1.0)
did_you_mean (1.5.0, default: 1.4.0, 1.2.1)
digest (3.0.0)
erubi (1.10.0, 1.9.0)
erubis (2.7.0)
etc (1.2.0, default: 1.1.0)
execjs (2.8.1, 2.7.0)
fcntl (default: 1.0.0)
fiddle (1.0.9, default: 1.0.0)
fileutils (1.5.0, default: 1.4.1)
forwardable (1.3.2, default: 1.3.1)
gdbm (default: 2.1.0)
getoptlong (0.1.1, default: 0.1.0)
globalid (0.5.2, 0.3.6)
hike (2.1.3, 1.2.1)
i18n (1.8.10, 1.8.8)
io-console (0.5.9, default: 0.5.6)
io-wait (0.1.0)
ipaddr (default: 1.2.2)
irb (1.3.7, default: 1.2.6)
jquery-rails (4.4.0, 4.3.5)
json (2.5.1, default: 2.3.0)
logger (1.4.3, default: 1.4.2)
loofah (2.12.0)
mail (2.7.1)
marcel (1.0.2, 1.0.1)
matrix (0.4.2, default: 0.2.0)
method_source (1.0.0)
mime-types (3.3.1)
mime-types-data (3.2021.0901, 3.2015.1120)
mimemagic (0.4.3, 0.3.5)
mini_mime (1.1.2, 1.0.2)
minitest (5.14.4, 5.13.0)
molinillo (0.8.0, 0.6.4)
multi_json (1.15.0, 1.14.1)
mutex_m (0.1.1, default: 0.1.0)
net-http-persistent (4.0.1, 3.1.0)
net-ldap (0.17.0, 0.16.1)
net-pop (0.1.1, default: 0.1.0)
net-protocol (0.1.1)
net-smtp (0.2.2, default: 0.1.0)
nio4r (2.5.8)
nokogiri (1.12.5 x86_64-linux, 1.11.7)
observer (0.1.1, default: 0.1.0)
open3 (0.1.1, default: 0.1.0)
openssl (2.2.0, default: 2.1.2)
ostruct (0.4.0, default: 0.2.0)
pkg-config (1.4.6, 1.4.4)
polyglot (0.3.5, 0.3.4)
power_assert (2.0.1, 1.1.7)
prime (0.1.2, default: 0.1.1)
pstore (0.1.1, default: 0.1.0)
psych (4.0.1, default: 3.1.0)
public_suffix (4.0.6, 3.0.3)
racc (1.5.2, default: 1.4.16)
rack (2.2.3, 2.1.4)
rack-openid (1.4.2)
rack-test (1.1.0, 0.7.0)
rails (6.1.4.1, 6.0.3.7)
rails-deprecated_sanitizer (1.0.4, 1.0.3)
rails-dom-testing (2.0.3)
rails-html-sanitizer (1.4.2)
rails-observers (0.1.5)
railties (6.1.4.1, 6.0.3.7)
rake (13.0.6, 13.0.3)
rbpdf (1.20.1)
rbpdf-font (1.19.1)
rdoc (6.3.2, default: 6.2.1.1)
readline (default: 0.0.2)
readline-ext (0.1.2, default: 0.1.0)
redcarpet (3.5.1)
reline (0.2.7, default: 0.1.5)
request_store (1.5.0)
rexml (3.2.5, default: 3.2.3.1)
rmagick (4.2.3)
roadie (4.0.0)
roadie-rails (2.2.0, 2.1.1)
rouge (3.26.1)
rss (0.2.9, default: 0.2.8)
ruby-i18n-months (1.0.0)
ruby-openid (2.9.2)
rubygems-update (3.2.29, 3.2.5)
sass (3.7.4)
sdbm (default: 1.0.0)
sdoc (2.2.0, 1.1.0)
singleton (0.1.1, default: 0.1.0)
sprockets (4.0.2, 3.7.2)
sprockets-rails (3.2.2, 3.2.1)
sqlite3 (1.4.2)
stringio (3.0.0, default: 0.1.0)
strscan (3.0.0, default: 1.0.3)
test-unit (3.4.8, 3.3.9)
thor (1.1.0, 1.0.1)
thread_safe (0.3.6)
tilt (2.0.10)
timeout (0.1.1, default: 0.1.0)
tracer (0.1.1, default: 0.1.0)
tzinfo (2.0.4, 1.2.6)
uri (0.10.1, default: 0.10.0)
webrick (1.7.0, default: 1.6.1)
websocket-driver (0.7.5, 0.6.3)
websocket-extensions (0.1.5)
xmlrpc (0.3.2, 0.3.0)
yaml (0.1.1, default: 0.1.0)
zeitwerk (2.4.2)
zlib (default: 1.1.0)

1 Answer 1

0

Redmine 4.x need Rails 5.2 branch only. You can find official Redmine requirements here.

So you should install required Rails version or upgrade Redmine too.

2
  • I'm not sure I'm following you. The version of Redmine I installed is from the testing branch, not even the stable (bullseye) one it doesn't exist yet and needs to be created in bullseye-backports. Therefeore, unless I compile an even more recent version, this is as high as I can upgrade Redmine, barring getting into experimental branch, which is usually not a good idea bugs.debian.org/cgi-bin/bugreport.cgi?bug=956365 Further, my rails version (6.1.4.1, 6.0.3.7) far exceeds the requirement (5.2). Or are you suggesting that I downgrade rails to exactly version 5.2? Oct 26, 2021 at 17:54
  • Yes, you can install rails from 5.2 branch. The latest now is 5.2.6. As for second option Redmine can be installed from GitHub source if you haven't use any plugins. If you have them they should be upgraded too but it's not always easy. Oct 27, 2021 at 3:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .