I've installed UFW (Uncomplicated Firewall) from the EPEL repo. When I try to allow connections to a non-default SSH port using ufw allow 22022/tcp, it fails with:

ERROR: problem running

The same error occurs with deny on an arbitrary port.

When I try to change the logging settings using ufw logging off, I get:

ERROR: Could not update running firewall

But UFW is not running (I triple checked it with ufw status and systemctl status ufw and ps aux | grep ufw). Any ideas how this problem can be solved?


These errors indicate that the firewall is not running. The commands are working nevertheless. You have to start the firewall in order to make the errors go away: systemctl start ufw.

But be careful if it's a remote server and you need SSH access: Don't lock yourself out. Make sure that your SSH port is allowed or the ufw service is not enabled so that you can simply restart your server if things go wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.