20

I have following problem. I am new to Linux and went with Mint as my distro. On windows I always used Chrome as my go to browser because I do a lot of webdev and like to have the best support for browser features so I also went for Google Chrome here on Linux. I found out that when I maximize the Screen of Chrome that the Window goes over the bounds of the screen. I couldn't replicate that behavior with any other application so it could be some issue with Chrome.

Does Chrome use GTK2 because it also overrides the Style of the installed theme?

I changed some dotfiles in my user directory and changed the default compositor to compton. There I just applied some settings to get a blur effect and transparent windows nothing too special.

This is my system specs output from neofetch:

  • OS: Linux Mint 20.2 x86_64
  • Host: 20287 Lenovo IdeaPad Z510
  • Kernel: 5.4.0-89-generic
  • Uptime: 10 hours, 50 mins
  • Packages: 2014 (dpkg)
  • Shell: bash 5.0.17
  • Resolution: 1920x1080
  • DE: Xfce
  • WM: Xfwm4
  • WM Theme: Sweet-Dark
  • Theme: Sweet-Dark [GTK2/3]
  • Icons: ePapirus [GTK2/3]
  • Terminal: xfce4-terminal
  • Terminal Font: Monospace 10
  • CPU: Intel i5-4200M (4) @ 3.100GHz
  • GPU: NVIDIA GeForce GT 740M
  • GPU: Intel 4th Gen Core Processor
  • Memory: 1984MiB / 7719MiB

enter image description here

As you can see in the screenshot the window decorations and scrollbar are outside of the screen which is quite annoying.

So my questions is if this could be due to some weird bug on chromes side or maybe due to some misconfigs on my side?

5
  • 2
    I'm also experiencing this after installing Linux Mint 20.2 yesterday, so a pretty clean install
    – QtizedQ
    Oct 24, 2021 at 19:04
  • 2
    This problem started for me last week on a Xubuntu install. I think its a recent regression.
    – blooop
    Oct 25, 2021 at 10:22
  • 1
    I have the same issue for a couple of weeks now both with latest chrome stable and chrome beta on Devuan 5 daedalus ceres + Xfce 4.16, kernel Debian 5.14.12-1. I have to manually maximize the windows as a workaround. In multi-monitor environment the overmaximized Chrome's window edge protrudes into other monitor's area side.
    – Csaba Toth
    Oct 28, 2021 at 16:44
  • 1
    Same issue on Debian 10 XFCE Nov 2, 2021 at 14:34
  • Same issue w/ Ubuntu 20.04.3, Chrome 95.0.4638.54
    – Toby
    Nov 28, 2021 at 23:18

3 Answers 3

16

UPDATE

Seems like it is fixed with this version: Version 96.0.4664.45 (Official Build) (64-bit)


seems like it is a bug within chrome. since no other window on my machine has this behavior and it just appeared after updating chrome..

found an open bug, too:

https://bugs.chromium.org/p/chromium/issues/detail?id=1261797&q=maximize&can=2

hope it gets fixed soon! ;)

3
  • Happens to me on Edge browser for linux as well.
    – Steve
    Nov 9, 2021 at 16:54
  • checked today on xubuntu 20.04 for chrome v 96.0.4664.45 . still seeing the issue.
    – Max
    Nov 21, 2021 at 12:45
  • This update/bug fix is now live in the dl.google.com stable repo. Assuming you are using the default Google Debian repo: sudo apt-get upgrade google-chrome-stable
    – Toby
    Nov 28, 2021 at 23:24
11

Upadate: Google Chrome Version 96.0.4664.93

Hurray! The window manager's maximize key now fits proper as well -- no edge bleeding. Lovely.


Update: Google Chrome Version 96.0.4664.45 on Xubuntu 21.10

When using Chrome's own title bar and borders clicking the title bar maximize button, or double clicking on the title bar itself, now maximizes correctly. Unfortunately, using the "maximize window" keyboard shortcut for the window manager still has the edges bleed over. Setting up a "fill window" key still works nicely.


Same here. Google Chrome 95.0.4638.69 on Xubuntu 21.10.

Looks like an issue when using Google Chrome's own title bar and borders.

If you turn on 'Use system title bar and borders' all seems to work fine but you have to live with the window title bar.

If you're like me and don't want a window title bar you can use a "fill window" key instead of maximizing the window (found in: Settings -> Window Manager -> Keyboard). For some reason 'fill window' fits proper even with Chrome's custom title bar and borders.

1
  • same here, but seems "Use system title bar and borders" option can also become oversized as time goes by... so need to toggle that checkbox back. seem this action make chrome recalculate geometry and work for some period of time...
    – Max
    Nov 11, 2021 at 14:34
2

I'm having the same behavior on Linux Mint 20.2 XFCE edition. The problem only occurs with Google Chrome, so I'll wait for the future fix.

Not the answer you're looking for? Browse other questions tagged or ask your own question.