1

My university wifi uses WPA2 Enterprise for students to connect with their logins and passwords and I cannot do it, network manager always says the password is incorrect and prompts me for another one even though the password is correct.

My problem is simmiliar to https://askubuntu.com/questions/279762/how-to-connect-to-wpa2-peap-mschapv2-enterprise-wifi-networks-that-dont-use-a-c but none of the solutions work for me. I use Fedora 34 Gnome, my wifi adapter model is Intel AX200

My /etc/NetworkManager/system-connections/UNIVERSITY.WIFI look like this

[connection]
id=UNIVERSITY.WIFI
uuid=0cdeb50f-03dd-45ba-85df-465027f0e12a
type=wifi
interface-name=wlp1s0
permissions=

[wifi]
hidden=true
mac-address-blacklist=
mode=infrastructure
ssid=UNIVERSITY.WFIFI
[wifi-security]
key-mgmt=wpa-eap

[802-1x]
eap=peap;
identity=my_login
password=my_password
phase2-auth=mschapv2

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]

1 Answer 1

1

Here's your answer:

Looks like after setting the phase 2 crypto settings with:

update-crypto-policies --set LEGACY

as indicated here: I was able to connect with no issues.

Your TLS certificate probably uses either SHA-1 (most likely) or RSA-1028 (less likely). Both are rejected now.

Test by downgrading your system policy to allow all crypto that was permitted in Fedora 32:

$ sudo dnf install crypto-policies-scripts
$ sudo update-crypto-policies --set DEFAULT:FEDORA32

If my guess is wrong, you'll want to revert to secure Fedora 33 default > settings:

$ sudo update-crypto-policies --set DEFAULT

TL;DR:

sudo update-crypto-policies --set LEGACY
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .