My wife has/had a Sony Xperia which the screen smashed. It had a few months worth of photos of the kids on it, which I would very much like to recover, but I can't spend several hundred dollars sending it away for recovery.

I seem to remember it had some issues charging prior to getting smashed which makes me think it might be related to this. It shows up in thunar under Devices, as 'F8332', but it won't mount, I think it might drop in and out, so I hope it's not a hardware issue which will be a total road block. I can run dmseg if anyone is interested. I can see it when I run lsusb and when I run $ adb shell I get "error: no devices/emulators found".

At this point I should note, I am not a smartphone person and I have never run adb before this fiasco and didn't even know what mtp was. Further, when I run `mtp-detect' I get:

libmtp version: 1.1.16
Listing raw device(s)
Device 0 (VID=0fce and PID=01e7) is a SONY XPeria XZ MTP.
   Found 1 device(s):
   SONY: XPeria XZ MTP (0fce:01e7) @ bus 2, dev 4
Attempting to connect device(s)
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0

Thanks in advance!


  • 1
    the phone is probably showing a dialog, asking if it should permit the PC to access files
    – jsotola
    Oct 23, 2021 at 5:41
  • Hi @Jsotola, I'm not convinced that is the only thing at play here, because it will make the connection chime irregularly. I guess that's what the sound is, I'm not that familiar with the phone. Regarding access to PC, in the research that I did last night I was expecting to be able to type adb shell to try and enable this, however the result will yield error: no devices/emulators found.
    – 1toneboy
    Oct 23, 2021 at 9:03


You must log in to answer this question.

Browse other questions tagged .