Kernel panic while install OpenBSD.

I tried installing the system but this is the error message that I have got:

Kernel panic.

Steps I tried:

  1. Reinstalling on the same ISO file.
  2. I have tried by reinstalling the ISO file and see if that fix the issue.

Thanks Jonathan Steadman.

The helpful guide I followed: https://www.openbsdhandbook.com/installation/

  • I've seen this happening when using a dynamically allocated disk image. Try using a pre-allocated disk image instead, one that won't grow. You could also just try again until it works. In any case, it probably has to do with the fact that VirtualBox needs to grow the disk image under the feet of OpenBSD, and it's unable to do it fast enough. I won't turn this into a real answer as it's just me waving my hands without proper proof.
    – Kusalananda
    Oct 22, 2021 at 15:23
  • @they thanks for your answer I will try that out later. :)
    – Jon
    Oct 22, 2021 at 15:40
  • What kind of HD controller are you using? If it's ATA/PATA try SATA or SCSI.
    – Krackout
    Oct 22, 2021 at 16:40

2 Answers 2


You need to change the VM from dynamically allocated to fixed size on the physical HDD.


Unchecking "enable I/O APIC" fixes this.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .