1

I'm trying to get my keyboard to use the us layout with variation altr-intl and no deadkeys.

Somehow my xorg-keyboard-config does not take effect. I looked up the config here arch-wiki but there seems to be a mistake in my config which I was unable to find.

My current (not working) config looks like this:

/etc/X11/xorg.conf.d/00-keyboard.conf

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "altgr-intl"
        Option "XkbOptions" "nodeadkeys"
EndSection

I get it to work by using the following command but as you might know this is not persistent:

setxkbmap -layout us -variant altgr-intl -option nodeadkeys

I don't want this command to end up in my xprofile file or such. I would prefere to do it in xorg as I did with my trackpad, mouse ect.

The keyboard I'm using is a keychron k2 connected by cable. Here is the output of xinput, in case the keyboard doesn't get identified correclty:

xinput list 

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Synaptics TM3053-003                      id=11   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=12   [slave  pointer  (2)]
⎜   ↳ Keytron Keychron K2                       id=15   [slave  pointer  (2)]
⎜   ↳ Logitech Wireless Mouse                   id=17   [slave  pointer  (2)]
⎜   ↳ Logitech Wireless Keyboard PID:4023       id=18   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=10   [slave  keyboard (3)]
    ↳ Keytron Keychron K2                       id=13   [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=14   [slave  keyboard (3)]
    ↳ Keytron Keychron K2                       id=16   [slave  keyboard (3)]
    ↳ Logitech Wireless Keyboard PID:4023       id=19   [slave  keyboard (3)]

I tried to identify the keyboard by using "MatchIsProduct" "Keytron Keychron K2" without any luck either.

I'm running manjaro i3 community edition. The keyboard settings set in the manjaro-settings are also the wanted layout so I don't think that these settings would mess up my xorg config. I'm trying this on a thinkpad T550.

With the current config I get the us keyboard without deadkeys but the altgr-intl variant is not active.

0

2 Answers 2

0

Can you check other config files that changing the keyboard settings. e.g 70-keyboard.conf or anothers. Or you can try rename the 00 to higher number.

I am not sure. That is my mind.

I think if X is starting succesfully config is not wrong. So it can be changed by another config.

1
  • Yes, xorg is starting normally. I got no other keyboard settings in xorg configured except for this one. I'm not sure what other settings could overwrite those. I will change the number of the file but I dont think that should make any difference.
    – Elfie
    Oct 21, 2021 at 7:57
0

/etc/X11/xorg.conf.d/00-keyboard.conf ... It's probably wise not to edit this file manually. Use localectl(1) to instruct systemd-localed to update it.

Somehow my xorg-keyboard-config does not take effect.

There should be no more /etc/X11/xorg.conf, instead xorg will generate those X11-files.

With systemd the keymap layout for the X11 server can be set using the localectl command. And see your locale with localectl command too.

  • list all X11 keyboard layouts with localectl list-x11-keymap-layouts
  • list all available variables localectl list-x11-keymap-variants
  • list all available options localectl list-x11-keymap-options
  • please take a look in this manpages man localectl too

Example:

localectl set-x11-keymap us altgr-intl terminate:ctrl_alt_bksp

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .