1

I recently got a Thinkpad T460 and am running Ubuntu 20.04 on it. I don't use a DE, just plain old i3.

I'm like to keep my hands on the keyboard. That's why I like the trackpoint. However, I keep accidentally touching the touchpad, resulting in unwanted mouse movements and even clicks (even though I barely touch it!)

I'm exploring multiple options to improve the situation. This question is about disabling the touchpad completely. According to xinput list, there is only one device (see below):

$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=12   [slave  keyboard (3)]

And if I run xinput disable 11, both trackpoint and touchpad are disabled.

How can I disable ONLY the touchpad?

9
  • 1
    maybe in system settings (BIOS)
    – jsotola
    Oct 20, 2021 at 17:46
  • That's odd. I have owned two T-series thinkpads, and am currently typing on one of them, and on both I had a separate entry for the touchpad and track point: SynPS/2 Synaptics TouchPad and TPPS/2 IBM TrackPoint on my T460p. We seem to basically have the exact same machine, and I can disable/enable the touchpad and trackpoint separately on my Arch (just tested now). Is there any way you may have parsed out the relevant entry in the output you show us?
    – terdon
    Oct 20, 2021 at 18:01
  • @jsotola Thanks, that was too obvious. Feel free to write an answer so I can accept it.
    – Sören
    Oct 20, 2021 at 18:04
  • @terdon I agree it's odd. I didn't change the output. Also notice how disabling one disables both.
    – Sören
    Oct 20, 2021 at 18:06
  • yeah, that's the really weird thing. Assuming we do have the same hardware (mine's a T460p bought almost 5 years ago now), it must come down to whatever software is recognizing it. If the BIOS option isn't a solution, you could try a different distro in case that makes a difference. I would be really curious to know if Arch, for example, gives you the same output.
    – terdon
    Oct 20, 2021 at 18:19

1 Answer 1

0

I came here with Fedora 37 activating a touchpad I don't want to use on my T470p.

Solution was very simple: Settings (gear icon)-->Mouse and Touchpad-->Touchpad section-->Touchpad toggle-->off.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .