2

I'm using Xubuntu 20.04. When I am trying to maximize google chrome, the maximize button, minimize button and the close button get above the visible screen area. enter image description here

1

Try to right click on top bar of Chome (where tabs are located), in a free area and then select Use system title bar and borders.

2
  • This is a workaround, but we used to be able to run Chrome without the option of using system title bar and borders. I think we will have to wait until the Chrome team fixes this bug. Oct 20 '21 at 13:04
  • It seemed strange to me because I was playing with my appearence settings and I wasn't sure what did I do wrong. But I realized that what I told you to do wasn't the fix, but a rather a workaround with the incovenience of the window manager bar above the browser.
    – sandrino
    Oct 20 '21 at 22:37
1

This is not a fix for the problem, but here's what I've done on my one workstation to remove the title bar from above Chrome 95 when it's maximized in XFCE.

  • In Chrome, enable the Use system title bar and borders option.
  • In the XFCE Window Manager Tweaks, enable the Hide title of windows when maximized.
  • In apps that have optional CSD, enable it. In an app like VS Code you would change the Window: Title Bar Style setting to custom.
  • Learn to live with the fact that some apps (MySQL Workbench, Thunderbird, etc.) now don't have min/max/close buttons in the window title bar anymore when they're maximized. Personally, I can do that all with the keyboard shortcuts so I don't mind too much.

My main takeaways:

  • I appreciate the extra vertical space that this setup gives me in other apps.
  • It helps me towards using the keyboard for all window management.
  • If I happen to be holding the mouse and I want to do things, I can always use a windows taskbar item to min/max/close it.

Before I tried the little experiment above, I did some research to find out what is actually going on with Chrome. Here is what happened: They switched off their custom X11 window management code in favor of using a library called Ozone which handles all the window management features for them.

Here are all the links I collected reading about this:

0

Same thing happened to me, right after I updated Google Chrome on Xubuntu 20.04. I downloaded the previous version from October 7th, 94.0.4606.81-1, and downgraded. On this version, the issue goes away. It's the same story for Chrome Beta and Unstable, the latest version causes some funky fullscreen behavior on Xubuntu.

Here's the deb for the previous version of Chrome: https://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_94.0.4606.81-1_amd64.deb

0

If you are using fedora, this might help:
wget https://dl.google.com/linux/chrome/rpm/stable/x86_64/google-chrome-stable-94.0.4606.71-1.x86_64.rpm

1
0

It looks like this problem is fixed in Chrome 96.0.4664.45, even when Use system title bar and borders is disabled.

I'm on Manjaro, XFCE 4.16.

1
  • After further testing, the window maximizes correctly when using the maximize button on the window decoration, but it still hides a little under the system bar when using the Win-↑ shortcut. Nov 17 '21 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.