My issue seems to be related to my Asus Zephyrus G15 having a Mediatek 7961 Wifi/Bluetooth adapter. I have read the posts where the support for this specific wifi adapter has been fixed in kernels 5.12/5.13; however, I've tried installing fresh Fedora, Ubuntu, and Elementary OS and updating the kernel to 5.14 and I'm still not able to see any ethernet or wifi settings. I'm currently connected to the internet by USB tether with my phone.

What my install process looks like

  1. Update BOOT settings to ignore linux distro
  2. Remove any partitions for an install linux distro
  3. Choose to install third-party services/software/drivers while installing from a boot drive
  4. Update install packages
  5. Upgrade installed packages
  6. Update the kernel to the latest or 5.14
  7. Reboot and check the current kernel with uname -r

Currently, I have Fedora installed and here's what I'm seeing:

> uname -r

> lsmod | grep 88
amdgpu               7802880  3

> sudo lshw -C network
  *-network UNCLAIMED       
       description: Ethernet controller
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 05
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list
       configuration: latency=0
       resources: ioport:d000(size=256) memory:fc700000-fc70ffff memory:fc710000-fc713fff
  *-network UNCLAIMED
       description: Network controller
       product: MEDIATEK Corp.
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm cap_list
       configuration: latency=0
       resources: iomemory:fe0-fdf iomemory:fe0-fdf iomemory:fe0-fdf memory:fe20300000-fe203fffff memory:fe20400000-fe20403fff memory:fe20404000-fe20404fff
       description: Ethernet interface
       physical id: 1
       bus info: usb@2:2
       logical name: enp6s0f3u2
       serial: 4a:c1:c0:5b:a0:8d
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=rndis_host driverversion=5.14.11-200.fc34.x86_64 duplex=half firmware=RNDIS device ip= link=yes multicast=yes port=twisted pair

> lspci -v | grep -A20 Ethernet
    Ethernet controller: Realtek Semiconductor Co., Ltd. Device 8162 (rev 05)
    Subsystem: ASUSTeK Computer Inc. Device 208f
    Flags: bus master, fast devsel, latency 0, IRQ 255, IOMMU group 12
    I/O ports at d000 [size=256]
    Memory at fc700000 (64-bit, non-prefetchable) [size=64K]
    Memory at fc710000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>

    Network controller: MEDIATEK Corp. Device 7961
    Subsystem: AzureWave Device 4680
    Physical Slot: 0-1
    Flags: fast devsel, IRQ 82, IOMMU group 13
    Memory at fe20300000 (64-bit, prefetchable) [size=1M]
    Memory at fe20400000 (64-bit, prefetchable) [size=16K]
    Memory at fe20404000 (64-bit, prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel modules: mt7921e

05:00.0 Non-Volatile memory controller: SK hynix Gold P31 SSD (prog-if 02 [NVM Express])
    Subsystem: SK hynix Gold P31 SSD
    Flags: bus master, fast devsel, latency 0, IRQ 57, NUMA node 0, IOMMU group 14

Reminder: if I'm not tethered to my phone, nothing shows except VPN

Reminder: if I'm not tethered to my phone, nothing shows except VPN

TL;DR I have a mediatek 7961 wifi adapter and regardless of the kernel (5.12/5.13/5.14) or the Linux distro, I cannot get my wifi/ethernet services to work.

  • I'm not sure this fix is permanent, but I unplugged all my peripherals, power source, etc., and hard restarted... Wifi and ethernet are working. Oct 19, 2021 at 12:56

1 Answer 1


So, the solution after doing everything above:

Don't just restart, shutdown, unplug everything, start back into the 5.14 kernel... Everything is working.

  • Have you tried installing asus-linux.org/wiki/fedora-guide on your machine yet? I'm using Ubuntu 21.10 with kernel 5.15 and have the same wifi issue (need to shut down, unplug and start back to re-enable it). Someone says using the above asus-ctl tool in Fedora will help, but I haven't had time to change to Fedora yet.
    – windyzboy
    Nov 4, 2021 at 7:05
  • This only makes WiFi work for me, Ethernet is still completely missing.
    – fromGiants
    Jan 18, 2022 at 10:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .