I have recently installed kernel 4.10.generic on ubuntu 18.04LTS sided by side with its own kernel version 5.4. Now grub shows me options to boot with both but only with kernel 4.10 selected i get error "load kernel first" other wise with kernel 5.4 it boots . I have also updated grub

sudo update-grub

and it finds all kernels but still same error appears while booting with 4.10. kernel.

1 Answer 1


If you have an UEFI system with Secure Boot enabled, this might happen because the 4.10 kernel is not properly signed for use with Secure Boot. Different UEFI implementations behave in different ways in this situation:some will present a Security Boot error message, others will just reject the attempt to load unsigned code, causing GRUB to display the "you have to load the kernel first" error message when it attempts to load the initramfs file after the kernel.

If you have already created a Machine Owner's Key (MOK for short), then you can use the private part of MOK and the pesign command to sign the kernel file. But if you want to use old kernels, it might be easier to disable Secure Boot in the BIOS settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.