0

Basically what happened is due to a known bug with duplicity I had to manually extract the difftar archives (Difftarchives?) Imagine my shock and slight horror when I saw that many files that ought to be regular files and not directory files were converted into directory files. For example, files that should be plain text are directories.

Relevant screenshot: The messed up files

5
  • You should indicates what is the error message of duplicity. If it is about the file download, you can download the file and try again duplicity with the local directory. If this doesn’t work, try the rdiffdir patch tool : it should apply to the base_dir the patches in the tar.gz file. Use the -z flag to decompress. Note : the documentation (man) is quite light. I may be wrong. Commented Oct 18, 2021 at 21:00
  • The specific error is that duplicity can't find a backup. I've tried with both the GUI tool deja dup and with duplicity.
    – NTibbitts
    Commented Oct 19, 2021 at 0:34
  • Did you launch duplicity with a distant (FTP, ssh, S3…) storage ? If you did, try to get the backup files back on your system, then use duplicity with the local directory to recover your files. Commented Oct 19, 2021 at 10:37
  • Yes, I tried to restore the files locally as well. Again, this is a KNOWN bug with Ubuntu. My question wasn't how to restore the backup, but how to patch the files back together again.
    – NTibbitts
    Commented Oct 19, 2021 at 18:03
  • But anyway, I fixed the problem. See my answer below.
    – NTibbitts
    Commented Oct 19, 2021 at 18:05

1 Answer 1

0

I'm kind of dumb. I forgot that you can use cat to concatenate files together. So, simply, cat folder.ext/* > filename.ext worked for me.

1
  • This could resolve full backups (is they are simply splitted directly), but not the incremental backups (an rdiff file should tel « this block has been modified like this », then if you have a database, you don’t save the whole directory. Commented Oct 19, 2021 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .