I have installed Debian 11 on a Dell Precision M6600 laptop. The ISO I installed does not include the non-free firmwares. My goal is to only install firmware and drivers necessary to get my WiFi adapter running rather than go the route of installing the unofficial ISO which includes a larger bundle of non-free firmware.

First I confirmed that my WiFi adapter is supported by the iflwifi kernel driver. According to this wiki, my Intel Centrino Ultimate-N 6300 is supported.

I also followed steps 1 & 2 of the instructions on the iwlwifi page under 'Installation' and added the 'contrib non-free' labels to /etc/apt/sources.list. My sources.list file now looks like this:

# See https://wiki.debian.org/SourcesList for more information.
deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free

deb http://security.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security/ bullseye-security main contrib non-free

However I wasn't able to simply install iwlwifi with apt because the machine had literally no internet connectivity at the time. Instead I downloaded the .deb file and installed it with dpkg -I . I obtained the .deb file here.

Now that I'm looking at the list of included drivers though, it doesn't explicitly include the Centrino Ultimate-N 6300 like the overall iwlwifi page says it should. So maybe this is the issue.

Step three is confusing. It says to run this command:

modprobe -r iwlwifi ; modprobe iwlwifi

I can run everything left of the ; and I get no errors but also no outputs. If I run the command as written I get

bash: modprobe: command not found

After several restarts the WiFi adapter is still not recognized. What I am looking to see is a list of available wifi networks when I click the icon in the task bar. I see the list after installing various distros including Mint 20, latest Ubuntu, and also the unofficial Debian 11 ISO that includes non-free firmware. I tried the latter as a test to see if Debian 11 can recognize this wifi card at all, which it can.

But currently, clicking the icon in the task bar only lists the wired connection and shows it unplugged, which is correct. No wifi networks are shown.

I may end up re-installing the unofficial ISO and living with it, but one of the things that appeals to me about Debian over other distros is the strictness about FOSS. Not necessarily because I personally feel the need to be that strict, but because there is less bloat on the system after a fresh install. I like the idea of only having the drives and firmware that are needed by the hardware instead of having a big bundle of stuff that isn't present.

What step am I missing to get my wifi adapter running in Debian 11?

  • 2
    Stupid question, but you are running modprobe as root?
    – Bib
    Commented Oct 17, 2021 at 20:38
  • Yes I'm prefacing the command with 'sudo' and I"m logged in as the root account Commented Oct 18, 2021 at 11:27

1 Answer 1


if you only need pakage firmware-iwlwifi; you need a system (a linux would be nice) with internet connection.

wget -c http://ftp.us.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-iwlwifi_20210315-3_all.deb

Save it on an usb-stick (or something similiar) Install the package with dpkg directly.

sudo dpkg -i /full/path/to firmware-iwlwifi_20210315-3_all.deb
    sudo modprobe -rv iwlwifi

Then you can load the modul again.

sudo modprobe -v iwlwifi
  • Thanks. That is the exact .deb file I downloaded. I also used the same dpkg command you pasted above to install it. I will try the subsequent modprobe commands. But will I have to run these modprobe commands just once or each time the system starts? Commented Oct 22, 2021 at 12:26
  • Maybe you have to install it after you start your installed debian again. I have not tested it, becaus I run debian 11 at the moment only as live session.
    – nobody
    Commented Oct 22, 2021 at 13:17
  • To download an updated version you can add non-free repos to /etc/apt/sources.list and then execute sudo apt update and sudo apt install firmware-iwlwifi
    – xonya
    Commented Sep 20, 2022 at 11:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .