0

I bought a new laptop, and my IT guy installed Windows 10 on it. It ran perfectly for one whole month,then updated, and went into "Not an authorized Microsoft Product" mode and locked me out. So I deleted the entire system, and installed Linux Mint.

It's perfect except that it cannot detect any wireless signals.

  • I ran
    nmcli d
    
    and it came out with
    wlan0 = lo
    wifi = Loopback
    State = unmanaged
    connection = --
    
  • Then I tried
    sudo lshw -C network
    
    and it responded with
    *-network UNCLAIMED
    description: Network controller
    product: Realtek Semiconductor Co.,Ltd.
    vendor: Realtek Semiconductor Co.,Ltd.
    physical id: 0
    bus info: pci@0000:01:00.0
    version: 00
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress cap_list
    configuration: latency=0
    resources: ioport:2000 (size=256) memory: d0600000 - d06fffff
    

It is my understanding that this tells me that there is hardware installed. That it is made by Realtek. However there isn't any software associated with it. It needs some software drivers to make it work. At least, that is what I think.

So I tried to find out what kind of software drivers I could use, and so I searched the internet (on a different computer. Remember this LinuxMint computer has no internet at all. Not even a CAT patch connector) and came up with a number of pages where people had this same problem. In general, every single one of them says use some version of one of these commands:

git clone -b v5.6.4.2 https://github.com/aircrack-ng/rtl8812au.git cd rtl*
wget -N -t 5 T 10 https://github.com/ubantuForums/wireless-info && chmod +X wireless-info && ./wireless-info

None of these solutions will work for me simply because I have no internet. I have to get the internet first, then I can download and install the driver. So all these suggestions of using this command, or plugging in a patch cable to access the internet is not working for me. My laptop does not have a female connector for a patch cable. And I need a driver.

I think what I need to do is perform these tasks manually without internet access. That is to say, get the file, put it on a USB, then install the file in (for example) the downloads directory and then install it from there. Like this maybe...

  1. Get on the internet (on a different computer) and obtain the rtl8812au or rtl8812ce file (I still don't know which one to use.)
  2. Put it on a USB.
  3. Extract it to the LinuxMint computer and put it into the downloads folder.
  4. Then run some command that looks something like this, maybe...
    cd downloads
    cd rtl8812au . X . X . X. (whatever the version is)
    make
    sudo make install
    sudo service Network Manager restart
    

I think. I am not a Linux expert, and I only started learning this week. But It makes sense to me. I have been installing Microsoft windows drivers for decades, so this must be similar.... right? Oh Nooooo!

I found websites that hold these drivers...

  • https://gnab/rtl8812au
  • https://aircrack-ng/rtl8812au
  • https://gordboy/rtl8812au
  • https://tomaspinho/rtl8812ce

But, you know, when I get to those websites, oh my goodness! Where are the files? When I read the internet comments they say "go to the pages XXXXX, and get the file, extract the ZIP, and install". Not so easy. Which is which, what are the files? As best I can tell, I am supposed to get the code directly. Compile it myself, make a file, ZIP the file and then try to install.

That can't be right, can it?

So obviously, I am all frustrated and confused, and probably look like some stupid kid to all you grizzly old coders out there, but it's all new to me. It's all strange to me, and you know, if I could get get over this hurtle, I think that I could really start loving this system... playing with it. doing things. It appeals to me. But first I need to get my wifi enabled.

So I need youse guys help in this.

I have one computer running Chinese Windows 10 that connects to the internet. I have some USB memory sticks. I have a new laptop with LunixMint ready to run, and I am all winning to make this thing work.

So here's what I need to solve this problem:

  • Instructions that a newbie like myself can understand.
  • A URL where to get whatever files I need, what to get, how to get it.
  • Installation instructions.

Do you all think that anyone can help me out on this? It would mean a lot to me.

2
  • ? Have you done : apt install firmware-realtek ........... and reboot ? Oct 15, 2021 at 12:46
  • I have tried this "apt install firmware-realtek" and response was "unable to locate firmware. unable to locate realtek". I will tell you that I have obtained the driver and I have unzipped it and pit it in my downloads folder. Now I am trying to use the linux commands to make and install. But, alas I am having trouble. I successfully get to the folder. then I use the make command "make". (After all there is a file called "Makefile") But what now? I get an error message "no rule to make target". This must be a simple mistake I am doing.
    – RufusV6
    Oct 15, 2021 at 23:52

1 Answer 1

0

Ok, you almost got there.

  1. Identify the wifi card you have, using commands like inxi -Fxz or sudo lshw -C network or lookup the info on your device manufacturer's website.
  2. Identify the driver via an internet search.
  3. If we assume rtl8812au is the correct driver, get the driver as a zip and put it on the machine where it needs to be installed. The websites you found are actually so called repositories on GitHub. You get files from GitHub either using a local install of git on your machine and then using the "git clone" command or downloading as zip. This is done by clicking on the green field "Code" and then "Download as ZIP".
  4. The driver from these repositories need to be compiled. To do this, extract the zip into a folder. Navigate into the folder (where the make file is) using the cd command. Then compile and install the driver using make and sudo make install.
  5. Reboot the machine.
11
  • This has been so very helpful to me so far.
    – RufusV6
    Oct 15, 2021 at 11:41
  • The error, "no rule to make target", actually means that some files to compile the driver are missing. They should be listed after the error message. Try to get the files or try a different source for the driver. Unfortunately, installing wifi drivers is the worst problem for new Linux users (especially on Laptops), especially if your machine has no internet connection. It might be easier to get a USB to ethernet dongle and get internet first to install the wifi driver. Oct 16, 2021 at 12:12
  • Yes. You are both understanding and informative. I know that I can find other drivers on the internet, and this remains an option. However, your suggestion to get a USB to ethernet dongle is the best suggestion so far. That is what I am doing now. I just ordered one and in a few days it should arrive. I fear however, that It might not work because the installation of Lunix-Mint did not have it installed when I installed, so it is likely that I do not have ethernet accessibility. Maybe I'll need to reinstall with the dongle, right?
    – RufusV6
    Oct 17, 2021 at 7:44
  • I found four archives of the driver on github. I successfully unpacked the zip in downloads. Then, I successfully ran "make". And it took a while line after line of code and then finished with no errors. Then I tried to "install", and there I had a problem. I didn't specify where to put it. So I used "install -t /lib/modules". It finished. Then I ran "sudo service networkmanager". No problem. Rebooted, and still no wifi. What did I do wrong?
    – RufusV6
    Oct 18, 2021 at 1:41
  • Ok, you should not need to reinstall after adding the dongle. Did you execute "sudo make install" exactly? using "sudo" (which means running the command as an administrator) is absolutely necessary for installing hardware drivers. What does "sudo lshw -class network -short" say afterwards? Oct 18, 2021 at 8:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .