1

I'm unable to startx without root permissions, as it throws me this error:

parse_vt_settings: Cannot open /dev/tty0 (permission denied)

When I run startx as root, either with sudo or by login, it works perfectly fine. I am currently running Gentoo Linux.

  • I've added the user I want to startx with to the tty group
  • I've added read and write permissions to tty0 for the tty group
  • I've deleted my .Xauthority file.

I've been trying to figure out this issue for about a day, and literally every single forum post I've come across has been of absolutely no use to me. Can I please get some help with this?

2
  • Please append output of loginctl to your question.
    – dirdi
    Nov 23 '21 at 14:58
  • @dirdi my installation that had this issue doesn't exist anymore, sorry.
    – leif.wav
    Nov 24 '21 at 20:03
1

From the Gentoo Wiki, running the elogind service solved my problem.

2
  • wait, how are you able to edit what i've said?
    – leif.wav
    Oct 17 '21 at 6:36
  • Many parts of SE can be confusing when starting out! Maybe start with our tour, then hit some of the Help Pages, in particular the one on editing. Welcome to U&L!
    – Jeff Schaller
    Nov 23 '21 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.