I tried an installation of Linux Mint 20.1 in dual boot with Windows 10 with a flash drive. My laptop is an asus R510V with an i5-6300HQ, 4GB of RAM and Intel HD graphics 530.

It looks like the installation has worked since half of my disk space has disappeared from my Windows partition (the proportion I specified when installing mint) but I can't launch Mint when booting. I don't have the GRUB option I am supposed to choose.

1 Answer 1


Common bootloader-not-changed-to-GRUB problem. If you are using UEFI, make sure you made a /boot/efi partition when you installed Mint and enter BIOS and set boot order to Mint first.

If it is a MBR use sudo grub-install --target=i386-pc /dev/sdX after booting and chrooting from the flash to write GRUB launcher in bootstarp area of the disk.

If you missed the EFI setup part, boot in the live media, make a partiton of more or less 512 MB, format it FAT, mark as bootable, chroot, mount it and run sudo grub-install --target=x86_64-efi --efi-directory=/path/to/mounted/partition --bootloader-id=GRUB

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .