0

For some weird reason, several programs have started to segfault when I try to run them without escalated privileges. Among these are gnome-abrt and variety which used to run fine without sudo up until yesterday; if I run them with sudo they work fine. I still haven't figured out if there are other applications that have the same issues but I am guessing that if I find out what is causing it for one of the applications, it will solve it for all of them.

The output I get from running e.g. gnome-abrt in the terminal is:

Segmentation fault (core dumped)

Any help is greatly appreciated.

EDIT: running sudo chown -R $USER:$USER $HOME && sudo restorecon -r $HOME seems to have created unexpected changes. Opening up Steam gives me this error:

Repairing installation, linking /home/myuser/.steam/steam to /home/myuser/.local/share/Steam
rm: cannot remove '/home/myuser/.steam/steam': Permission denied
Setting up Steam content in /home/myuser/.local/share/Steam
ln: failed to access '/home/myuser/.steam/steam': Permission denied

Please help me "undo" this command.

EDIT 2: those two particular packages were updated today, so it seems that something has gone wrong on the devs' end.

17
  • Linux distro? Version of the distro? Are the packages up to date?
    – D4RIO
    Oct 7, 2021 at 14:18
  • Fedora 34 and, yes, everything is up-to-date. When I opened abrt (using sudo) and tried to report several of the issues, it told me that there was 'too little valuable .information'
    – telometto
    Oct 7, 2021 at 14:23
  • 1
    @Artem in those commands the variables are expanded by the shell before sudo sees them ;-). Oct 7, 2021 at 14:32
  • @ArtemS.Tashkinov I tried both with variables and whole paths and user but they didn't work :/
    – telometto
    Oct 7, 2021 at 14:34
  • Ok, I tried opening up a random program now and it seems that something else happened. Please check my edit.
    – telometto
    Oct 7, 2021 at 14:39

1 Answer 1

1

One or more of the shared libraries (*.so) used by the failing programs has probably had its permissions changed.

Compare the results of

sudo ldd $(type -p programname)
# and
ldd $(type -p programname)
2
  • I tried ldd $(type -p gnome-abrt) both with and without sudo and both times it yields not a dynamic executable.
    – telometto
    Oct 7, 2021 at 21:36
  • gnome-abrt is a python application. It's not that easy to follow its dependencies. Oct 8, 2021 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.