1

enter image description hereenter image description hereI'm making a hackers lab, so I downloaded Kali Linux and Metasploitable and set them on VirtualBox running on a Windows 10 host machine. The host system is using a wired connection, which both guests also must use. The host has full internet access.

When I configure the VM network interfaces in NAT mode, they get IP addresses and access to the internet, but the lab requires using a Bridged network. When I configure them as bridged adapters, For Bridged connection I select "Realtek PCIe GbE Family Controller" with promiscuous mode set to "deny" and "Cable connected" ticked. In both systems ifconfig shows eth0 doesn't even get an IP address.

Metasploitable doesn't have a GUI. Kali does not change to wired network and show me the available networks because I also use a WIFI adapter, it says wired connection 1, but does not work and the network symbol is spinning and it cannot connect to the internet.

I tried changing the adapter types to all the types there are with promiscous mode: allow VMs, but still nothing worked.

9
  • 1
    Please edit your question and give us (a lot) more detail. Are you installing metasploitable or Kali? Are these virtual machines or not? If yes, who is the host and who is the client? What "little circle"? What are your current network settings and network layout? What should they be instead? What errors do you get ("cannot use the broswer" doesn't tell us anything: does the browser not load or does it not open webpages? Is it a DNS issue? Something else?). The more detail you give us, the better your chances of getting an answer.
    – terdon
    Oct 7, 2021 at 10:17
  • There, i rewrote it, this is the best i can do, english is not my first language
    – TommyThe0G
    Oct 7, 2021 at 12:17
  • Don't worry about the English, your English is fine! It's the lack of information that is problematic. We need to know what is the host machine, and what is the VM. A screenshot of the relevant settings would also be helpful. We need to know what network you are changing to bridged. We also need to know if the host can connect to the internet, and any other relevant information.
    – terdon
    Oct 7, 2021 at 12:49
  • Host machine: windows 10 pro VM: virtualbox running kali linux and metasploitable. I dont know how to answer to the "network im changing". Yes the host machine(windows 10 pro) can connect to the internet.
    – TommyThe0G
    Oct 7, 2021 at 13:24
  • 1
    Probably problem releted to PCIe passthrough or whatever the reason most Kali VM questions are asked for. Oct 7, 2021 at 14:21

1 Answer 1

0

Just two simple methods you apply on your virtual machine.

Method 1: File>Preferences>Network>+Add NAT Network>OK Go to Metasploitable>Setting>Network>Attach to: Nat Network and Name: NatNetwork>Advance>Promiscuous mode: Allow VMs>OK

Method 2: File>Preferences>Network>+Add NAT Network>Edit Network and Change: Network CIDR 192.168.10.0/24>OK Go to Metasploitable>Setting>Network>Attach to: NAT Network and Name: NatNetwork>Advance>Promiscuous mode: Allow VMs>OK

Note: if can't change Metasploitable IP address, type the command: sudo dhclient and type password change IP address.

Now you go to Kali terminal and ping the Metasploitable IP.

Watch the "Installation of Metasploitable 2 and connecting it with Kali in VirtualBox" video

1
  • I find your instructions ("Method 1" and "Method 2") to be hard to read.   Please try to make them clearer, perhaps by adding formatting (e.g., separate steps on separate lines) and/or adding words. Sep 13, 2022 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .