0

I have a problem where I am not able to install anything or update my system from both terminal and the AppCenter. When I install updates it says:

Error while installing package: trying to overwrite '/usr/share/metainfo/granite.appdata.xml', which is also in package libgranite-common 6.1.1+r2107+pkg120~ubuntu6.1. 

In terminal I get an error of:

The following packages have unmet dependencies:
[package name] : Depends: libgranite5 (>= 0.2.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I tried removing libgranite5.deb but it's being created again. I also did sudo apt --fix-broken install and I got the same error Any ideas? Thanks in advance!

2
  • And did you try the command apt --fix-broken install? Please don't answer in a comment, edit your question instead to add new info. Oct 6, 2021 at 15:36
  • @Peregrino69 yes, and I also edited the answer
    – Someone
    Oct 6, 2021 at 16:06

1 Answer 1

1

The granite package is buggy:

Bug #1939741

package libgranite5 (not installed) failed to install/upgrade: trying to overwrite '/usr/share/metainfo/granite.appdata.xml', which is also in package libgranite-common 6.1.0+r2071+pkg119~ubuntu6.1

1
  • But how do I fix it? I couldn't remove the file or uninstall it. (Also I was trying to install elementary tweaks too)
    – Someone
    Oct 6, 2021 at 18:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .