0

Running sudo os-prober does not work.

Running sudo grub-install /dev/sda1 does not work.

I've tried going on the grub.d 40_custom file and editing it to include a boot option, specifying the windows efi partition, which my system is able to detect, and it didn't work.

I'm running a fresh installation of Linux Mint XFCE 20.2 on an HDD. My Windows 10 is on an SSD. I've had the two dual-booted before but recently I had to reinstall my Linux Mint, so I did a full format of the HDD and installed it.

Just to be clear: I installed Linux XFCE on a formatted HDD after having Windows 10 already installed on an SSD.

In the installation menu the SSD partitions did show up, the live boot recognised them, it just isn't detecting it now.

I've also tried mounting the SSD and trying to detect it with os prober, I've even went on the "disks" app that is preinstalled to mount the efi as well. Nothing is being detected by GRUB, I don't know what else to do.

Also, even though it says that the mount point of the sda's (the windows partitions) is in the mnt folder, whenever I mount them through the GUI manually, they show up in the media folder. I don't know what that's about but it could be related.

1
  • You may have accidentally booted the Linux Mint installer in legacy BIOS style, resulting in the installation of legacy BIOS-style GRUB. Once the BIOS compatibility support has activated, there is no way back to UEFI without rebooting, and the BIOS-style GRUB will not be able to chainload the Windows UEFI bootloader, and so it makes no sense for os-prober to detect it either. If possible, change your BIOS settings to "UEFI only" (a.k.a "disable CSM") and reinstall Mint in UEFI mode, then os-prober should see Windows just fine.
    – telcoM
    Oct 3, 2021 at 9:16

1 Answer 1

1

@telcoM, you hit the nail on the head. Didn't even think to check if the installation was UEFI or not. Reinstalled it with the USB and saw that the first boot option wasn't it, so I changed it and voila. Didn't even have to put anything into grub, it just detected Windows 10 and automatically set a menu entry.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .