3

I have set the touchpad speed slider to ~50% in Mouse & Touchpad Settings. I find this good enough most of the time but if I move my finger a bit too fast, the pointer flies to the edge/corner. If I set the touchpad speed too low, the small movements require multiple swipes.

I want to lower the acceleration to match it with the "precision touchpad" of Windows, which is perfect (or disable acceleration if acceleration can't be lowered).

$ cat /proc/bus/input/devices gives the following result:

I: Bus=0018 Vendor=06cb Product=cd41 Version=0100
N: Name="SYNA7DB5:01 06CB:CD41 Touchpad"
P: Phys=i2c-SYNA7DB5:01
S: Sysfs=/devices/platform/AMDI0010:01/i2c-0/i2c-SYNA7DB5:01/0018:06CB:CD41.0001/input/input10
U: Uniq=
H: Handlers=mouse1 event7 
B: PROP=5
B: EV=1b
B: KEY=e520 10000 0 0 0 0
B: ABS=2e0800000000003
B: MSC=20

From # libinput list-devices:

Device:           SYNA7DB5:01 06CB:CD41 Touchpad
Kernel:           /dev/input/event7
Group:            8
Seat:             seat0, default
Size:             103x75mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   flat *adaptive
Rotation:         n/a

I tried # libinput "AccelProfile" "flat" but it tells me libinput: libinput-AccelProfile is not installed. I did # dnf search libinput and installed all the packages:

libinput.x86_64 : Input device library
libinput-devel.x86_64 : Development files for libinput
libinput-test.x86_64 : libinput integration test suite
libinput-utils.x86_64 : Utilities and tools for debugging libinput
xorg-x11-drv-libinput.x86_64 : Xorg X11 libinput input driver
xorg-x11-drv-libinput-devel.x86_64 : Xorg X11 libinput input driver development
                                   : package.

but the result stays the same.


OS Name: Fedora 34 (Workstation Edition)
OS Type: 64-bit
GNOME Version: 40.0.0
Windowing System: Wayland

1 Answer 1

1

I don't know if you've already done so, but you can download gnome-tweaks and set the pointer acceleration there, through the GUI. If that doesn't work, please let me know and, if it doesn't, I'll see if I can help you with an alternative way to adjust it.

EDIT: I tried searching the settings using the CLI but to no avail. gsettings set org.gnome.desktop.peripherals.mouse has accel-profile which can be adjusted; unfortunately, gsettings set org.gnome.desktop.peripherals.touchpad only gives the following options: click-method, disable-while-typing, edge-scrolling-enabled, left-handed, middle-click-emulation, natural-scroll, send-events, speed, tap-and-drag, tap-and-drag-lock, tap-button-map, tap-to-click, two-finger-scrolling-enabled. So it looks like you're out of luck.

Another thing worth mentioning is that for Wayland, there is no libinput configuration file. The configurable options depend on the desktop environment's support for them. It is, however, odd that changing the option in gnome-tweaks does not yield the expected result, as that works on my laptop. My guess is that there is something not working properly/hardware support issues with your particular model of touchpad.

The only thing I could recommend trying is to install dconf-editor to see if that allows you to adjust it using the GUI.

4
  • Sorry, I forgot to mention - there is no option for the touchpad acceleration (profile) in gnome-tweaks. I have set the mouse acceleration profile to flat, but that doesn't affect the touchpad acceleration. Commented Sep 30, 2021 at 14:37
  • Please check the edit.
    – telometto
    Commented Sep 30, 2021 at 17:48
  • The only thing related to the touchpad speed in dconf-editor is /org/gnome/desktop/peripherals/touchpad/speed, which doesn't offer anything more than the vanilla Settings GUI/CLI. At the current level of acceleration, it is unusable. Commented Oct 1, 2021 at 9:00
  • @user1029387 libinput handles touchpad acceleration slightly differently, see wayland.freedesktop.org/libinput/doc/latest/… Commented Mar 18, 2022 at 7:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .