0

I'm getting a bunch of conflict error messages regarding the updating of packages containers-common and runc on my CentOS 8 server.

Yum output:

/root>yum update --nobest
Last metadata expiration check: 0:16:51 ago on Fri 24 Sep 2021 03:59:35 PM EDT.
Dependencies resolved.

 Problem: package containers-common-1:1.3.1-5.module_el8.4.0+886+c9a8d9ad.x86_64 requires runc, but none of the providers can be installed
  - package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-70.rc92.module_el8.4.0+673+eabfc99d.x86_64
  - installed package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-70.rc92.module_el8.4.0+673+eabfc99d.x86_64
  - package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-73.rc93.module_el8.4.0+830+8027e1c4.x86_64
  - installed package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-73.rc93.module_el8.4.0+830+8027e1c4.x86_64
  - package containerd.io-1.4.9-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-74.rc95.module_el8.4.0+886+c9a8d9ad.x86_64
  - installed package containerd.io-1.4.9-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-74.rc95.module_el8.4.0+886+c9a8d9ad.x86_64
  - cannot install the best update candidate for package containers-common-1:1.2.2-10.module_el8.4.0+830+8027e1c4.x86_64
  - cannot install the best update candidate for package containerd.io-1.4.9-3.1.el8.x86_64
  - package runc-1.0.0-56.rc5.dev.git2abd837.module_el8.3.0+569+1bada2e4.x86_64 is filtered out by modular filtering
  - package runc-1.0.0-64.rc10.module_el8.4.0+522+66908d0c.x86_64 is filtered out by modular filtering
  - package runc-1.0.0-65.rc10.module_el8.4.0+819+4afbd1d6.x86_64 is filtered out by modular filtering
  - package runc-1.0.0-70.rc92.module_el8.4.0+786+4668b267.x86_64 is filtered out by modular filtering
  - package runc-1.0.0-71.rc92.module_el8.4.0+833+9763146c.x86_64 is filtered out by modular filtering
================================================================================================================================
 Package                      Architecture      Version                                              Repository            Size
================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 runc                         x86_64            1.0.0-70.rc92.module_el8.4.0+673+eabfc99d            appstream            3.1 M
 runc                         x86_64            1.0.0-73.rc93.module_el8.4.0+830+8027e1c4            appstream            3.2 M
 runc                         x86_64            1.0.0-74.rc95.module_el8.4.0+886+c9a8d9ad            appstream            3.3 M
Skipping packages with broken dependencies:
 containers-common            x86_64            1:1.3.1-5.module_el8.4.0+886+c9a8d9ad                appstream             95 k

Transaction Summary
================================================================================================================================
Skip  4 Packages

Nothing to do.
Complete!
/root>

I tried the suggestion to use the --best --allowerasing flags, but it shows that my docker environment would be corrupted by removing some important packages.

/root>yum update containers-common --best --allowerasing
Last metadata expiration check: 0:30:49 ago on Fri 24 Sep 2021 03:59:35 PM EDT.
Dependencies resolved.
================================================================================================================================
 Package                          Architecture  Version                                          Repository                Size
================================================================================================================================
Upgrading:
 containers-common                x86_64        1:1.3.1-5.module_el8.4.0+886+c9a8d9ad            appstream                 95 k
Installing dependencies:
 runc                             x86_64        1.0.0-74.rc95.module_el8.4.0+886+c9a8d9ad        appstream                3.3 M
Removing dependent packages:
 containerd.io                    x86_64        1.4.9-3.1.el8                                    @docker-ce-stable        112 M
 docker-ce                        x86_64        3:20.10.8-3.el8                                  @docker-ce-stable         95 M
 docker-ce-rootless-extras        x86_64        20.10.8-3.el8                                    @docker-ce-stable         16 M

Transaction Summary
================================================================================================================================
Install  1 Package
Upgrade  1 Package
Remove   3 Packages

Total download size: 3.4 M
Is this ok [y/N]: N

Is there a permanent workaround for these package update conflicts?

0

Removing the podman package, and running sudo yum autoremove to fix its unused dependenices fixed this for me.

1
  • The yum autoremove command fixed the problem for me. Apparently, I don't have podman installed: Sep 29 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.