0

So I have Debian 11 (Bullseye) installed on a NUC11PAHi5. Everything seemed to be working fine so far, however this morning I discovered that Bluetooth is actually not working when I tried to pair up some headphones.

In Settings, when I go to Bluetooth, it shows it as off. I can switch it on, but the switch is all that changes. If I go to a different settings pane and back, Bluetooth is back off again.

uname -a:

Linux NUCTUX 5.10.0-8-amd64 #1 SMP Debian 5.10.46-4 (2021-08-03) x86_64 GNU/Linux

When I run sudo dmesg | grep tooth, I get:

[    3.787615] Bluetooth: Core ver 2.22
[    3.787629] Bluetooth: HCI device and connection manager initialized
[    3.787632] Bluetooth: HCI socket layer initialized
[    3.787634] Bluetooth: L2CAP socket layer initialized
[    3.787636] Bluetooth: SCO socket layer initialized
[    3.794108] Bluetooth: hci0: Bootloader revision 0.4 build 0 week 30 2018
[    3.795110] Bluetooth: hci0: Device revision is 2
[    3.795111] Bluetooth: hci0: Secure boot is enabled
[    3.795112] Bluetooth: hci0: OTP lock is enabled
[    3.795112] Bluetooth: hci0: API lock is enabled
[    3.795113] Bluetooth: hci0: Debug lock is disabled
[    3.795114] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    3.795136] bluetooth hci0: firmware: failed to load intel/ibt-19-0-4.sfi (-2)
[    3.795176] bluetooth hci0: Direct firmware load for intel/ibt-19-0-4.sfi failed with error -2
[    3.795178] Bluetooth: hci0: Failed to load Intel firmware file (-2)
[    5.670228] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.670229] Bluetooth: BNEP filters: protocol multicast
[    5.670232] Bluetooth: BNEP socket layer initialized

where failed to load intel/ibt-19-0-4.sfi (-2) looks like a potential cause of my issue, but searching for that message has yielded next to no results.

I initially had wifi disabled in the UEFI manager, since I'm not using it, but turning it on made no difference.

Anyone run into this, or have any pointers? Thanks in advance!

2

firmware: failed to load intel/ibt-19-0-4.sfi is the exact reason why it doesn't work.

You need to install firmware-iwlwifi from the non-free repo: https://packages.debian.org/buster-backports/firmware-iwlwifi

Here's a howto: https://wiki.debian.org/iwlwifi

1
  • Thank you very much, glad I was at least headed in the right direction :-D One reboot later and bam, like a charm! Sep 23 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.