0

I have 256GB Intel SSD 2500 Pro series disk. It worked great on Linux Ubuntu. Now it stopped to work. Now it is detected as follows:

[69214.467957] scsi 6:0:0:0: Direct-Access     SandForc e{200026BB}           PQ: 0 ANSI: 5
[69214.468294] sd 6:0:0:0: Attached scsi generic sg3 type 0
[69214.468486] sd 6:0:0:0: [sdc] 64 512-byte logical blocks: (32.8 kB/32.0 KiB)
[69214.468746] sd 6:0:0:0: [sdc] Write Protect is off
[69214.468748] sd 6:0:0:0: [sdc] Mode Sense: 28 00 00 00
[69214.469020] sd 6:0:0:0: [sdc] No Caching mode page found
[69214.469026] sd 6:0:0:0: [sdc] Assuming drive cache: write through                                                                   
[69214.537252] sd 6:0:0:0: [sdc] Attached SCSI disk

Is it a disk or firmware failure ? Should I try to update the disk firmware ?

Update 1: I tried to update firmware by using Intel Firmware Update Tool but the tool does not recognize the disk (in this state) as an Intel SSD.

3
  • 1
    I had a similar issue years back with a samsung drive. I sent it in to samsung for repair and flashing firmware is what they listed as the fix. Could be worth a try.
    – jordanm
    Sep 21, 2021 at 22:20
  • Answered here I thinkl... superuser.com/questions/1604044/…
    – Bib
    Sep 22, 2021 at 14:04
  • @Bib my drive is being recognized exactly as SandForce{200026BB} . Thanks I will try the procedure Sep 23, 2021 at 16:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.