1

When I remote connect from Windows 10 (using the default Windows RDP client) to my Linux Mint 20.1 remote machine (running xrdp), I would like to be able to play sound on the remote machine. However, in the sound settings I see that the output device is "Dummy Sound" and no audio will play. My Google-fu has mostly yielded solutions about using pulseaudio to redirect the sound back to the Windows client machine, but this is not exactly what I'm looking to do. The remote Linux Mint machine has its own speakers which I would like to use to hear the audio when I am remotely connected to this machine. Has anyone ever experienced this issue and found a workaround?

Dummy Sound screenshot

2
  • IIRC windows rdp client has an option to play sound on remote computer. Have you tried that? Sep 21, 2021 at 18:00
  • Yes, in the Windows RDP client under Local Resources > Remote audio > Settings, I have Remote audio playback set to "Play on remote computer." fwiw, the "Play on this computer" setting here does not work either.
    – mfcallahan
    Sep 21, 2021 at 19:42

1 Answer 1

0

Many major distributions grant access to sound devices by default for local login sessions only.

On Debian/Ubuntu there is a standard user group audio which allows its members the use of audio devices at all situations: I would expect Mint to have it too.

Just use sudo usermod -a -G audio $(whoami) to add your user account to the group, and then you should be allowed to use the Linux system's sound devices even on remote sessions, cron jobs, or whatever.

Remember that you must log out your existing session and login again for the group membership change to take effect within the session.

1
  • I did add my username to the audio group, however the issue still persists.
    – mfcallahan
    Sep 21, 2021 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.