1

I tried to create a file /etc/sysctl.d/10-network-override.conf then sudo systemctl daemon-reload

net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1
net.ipv6.conf.lo.disable_ipv6=1
net.ipv6.conf.wls1.disable_ipv6=1

Also, tried creating /etc/systemd/network/20-IpV6-disable.network then systemctl restart systemd-networkd

[Match]
Name=wls1
[Network]
DHCP=ipv4
LinkLocalAddressing=ipv4
IPv6AcceptRA=no

Both solutions work temporarily and after rebooting I get IPv6 again.

1 Answer 1

0

I use just these two settings which are enough:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1

You will continue to see IPv6 addresses assigned to your interfaces but that's OK because they are Link Local addresses and can only be used within your LAN. These addresses are not routable.

If you want to go even further, you can simply disable the ipv6 kernel module, create a file e.g. /etc/modprobe.d/disable-ipv6.conf with this:

blacklist ipv6

and reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .