0

Hello fellow Linux users, hope you are enjoying your setup.

It turns out that I've been running into a weird problem lately, which is about the wireless connection being slow; I'm only getting like 4-6 mbps, or fewer, out of 30. The strange fact, is that it happens on every single distribution, but now that I'm running an arch based distro (Arco Linux), I've found out that the problem is solved after unloading and loading the driver with sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci ; I haven't tried this workaround yet on other non-rolling release distros.

I don't know when it started to happen, as I was running windows (which I ditched to come back to linux now), but if I remember correctly it didn't happen like 3 months ago when I was running just Linux as my daily driver. I might add as well that I have already tried some LTS kernel versions; none of them seemed to work though.

My question is, is there any way to solve this, so I don't have to execute the command mentioned above every time I boot to get the full Wi-Fi speed back?

I'm on the latest kernel 5.14.6-arch1-1 with the latest linux-firmware. Here's some other info:

❯ lspci -k (I removed the other lines, for you to see just the Network Controller info)

> Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network
> Adapter (rev 31) 
>         Subsystem: Dell Device 1810 
>         Kernel driver in use: ath10k_pci 
>         Kernel modules: ath10k_pci

    ❯ iwconfig

 

> lo        no wireless extensions. 
> 
>   enp2s0    no wireless extensions.
> 
> wlp1s0    IEEE 802.11  ESSID:"HOME-1100"   
>           Mode:Managed  Frequency:2.437 GHz  Access Point: 44:32:C8:EB:11:00    
>           Bit Rate=1 Mb/s   Tx-Power=20 dBm    
>           Retry short limit:7   RTS thr:off   Fragment thr:off 
>           Power Management:off 
>           Link Quality=70/70  Signal level=-33 dBm   
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0 
>           Tx excessive retries:0  Invalid misc:239   Missed beacon:0

 

    

    ❯ sudo  dmesg | grep firmware 

> [    0.100764] Spectre V2 : Enabling Restricted Speculation for
> firmware calls  
[    3.947477] i915 0000:00:02.0: [drm] Finished
> loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)  
[    4.272625]
> ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api
> 6 features wowlan,ignore-otp crc32 42e41877  
[    4.793040] Bluetooth:
> hci0: QCA: patch rome 0x302 build 0x3e8, firmware rome 0x302 build
> 0x111  
[  209.985228] ath10k_pci 0000:01:00.0: firmware ver
> WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32
> 42e41877

If you guys need any other info, please let me know. Thanks in advance for your help.

2
  • This is a really bad WiFi controller: bugzilla.kernel.org/… You could go file a new bug report but considering the sheer amount of already existing ones I wouldn't hold my breath. Sep 20, 2021 at 7:56
  • Oh, I see. What concerns me is that it used to work just fine some months ago, as I mentioned. Perhaps the problem relies on the new kernel changes. Sep 20, 2021 at 17:41

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.