2

My computer is a former laptop from which I removed the screen. The graphics card is an ATI Radeon of some kind. I have it plugged into a small TV via VGA cable, but Mint still thinks I have the original laptop screen too. The external monitor displays in 1024x768 resolution, but when I use game consoles, and the two times I tested Mageia Linux, it displays in 1280x800 [EDIT: I forgot, it was only the first time with Mageia 1, Mageia 2 didn't suport it]. This resolution is also available for the laptop screen. I want to get the widescreen display to work for the computer, but Mint isn't allowing it.

I've been looking at this page: https://wiki.ubuntu.com/X/Config/Resolution

xrandr -q outputs this (not including the part below about the laptop monitor):

$ xrandr -q
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  

I ran cvt

$ cvt 1280 800 60
# 1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

Then I copied that to xrandr, but xrandr didn't like it. When I sudo tried again it gave me this:

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  25
  Current serial number in output stream:  25

Does anybody know how to fix this?

1 Answer 1

0

Since posting this question I have found a partial solution. I looked at instructions on ArchWiki (https://wiki.archlinux.org/index.php/Xrandr) and found that they worked (even though I tried them before; I don't know what I was doing wrong then). By following the instructions on that page, I was able to change to widescreen mode with xrandr.

My problem now is that my screen appears blurry in widescreen mode. This bothers me a lot because I'm used to very sharp graphics that allow 8-point and smaller fonts to be fully readable. I'm guessing that some of the numbers produced by cvt and gtf weren't optimal for my screen.

Since I remembered Mageia getting it right, I tried burning a two different Mageia LiveCDs and booting them to get the xorg.conf settings. I was dissapointed to find that LiveCD mode didn't enable widescreen. That means that if I want those settings, I would have to install Mageia to the HDD just to copy the settings from xorg.conf. Since I don't want to do that, I am content to assume that it would work, while staying in fullscreen mode.

3
  • I forgot to mention this when I discovered it, but I still have Mageia installed on an old HDD. I copied the xorg.conf, but it was still blurry. It seems that I'm not getting widescreen because it just doesn't work properly.
    – Wutaz
    Sep 30, 2013 at 15:23
  • Have you tried turning off the broken internal monitor? --off Disables the output. --auto will reenable a disabled monitor so remove --auto and add --off for the LVD output.
    – rjt
    Jul 4, 2014 at 6:30
  • I got a new computer with a better graphic card since asking this question, and I now know that my monitor's maximum resolution was 1360x768, not 1280x800. That was probably why I was really having problems.
    – Wutaz
    Jul 6, 2014 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .