2

My trackpad works fine, but the moment I press a button on my keyboard, the mouse freeze and I can not use my trackpad anymore. When I release the key the trackpad works again. This is an issue for some software where I would like to continue using my keyboard while moving the mouse

I am on Ubuntu 20.04 on a DELL laptop

Output of xinput list-props for the touchpad id

Device 'DELL07E6:00 06CB:76AF Touchpad':
    Device Enabled (172):   1
    Coordinate Transformation Matrix (174): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (327): 1
    libinput Tapping Enabled Default (328): 0
    libinput Tapping Drag Enabled (329):    1
    libinput Tapping Drag Enabled Default (330):    1
    libinput Tapping Drag Lock Enabled (331):   0
    libinput Tapping Drag Lock Enabled Default (332):   0
    libinput Tapping Button Mapping Enabled (333):  1, 0
    libinput Tapping Button Mapping Default (334):  1, 0
    libinput Natural Scrolling Enabled (311):   1
    libinput Natural Scrolling Enabled Default (312):   0
    libinput Disable While Typing Enabled (335):    1
    libinput Disable While Typing Enabled Default (336):    1
    libinput Scroll Methods Available (313):    1, 1, 0
    libinput Scroll Method Enabled (314):   1, 0, 0
    libinput Scroll Method Enabled Default (315):   1, 0, 0
    libinput Click Methods Available (337): 1, 1
    libinput Click Method Enabled (338):    1, 0
    libinput Click Method Enabled Default (339):    1, 0
    libinput Middle Emulation Enabled (340):    0
    libinput Middle Emulation Enabled Default (341):    0
    libinput Accel Speed (318): 0.000000
    libinput Accel Speed Default (319): 0.000000
    libinput Left Handed Enabled (323): 0
    libinput Left Handed Enabled Default (324): 0
    libinput Send Events Modes Available (292): 1, 1
    libinput Send Events Mode Enabled (293):    0, 0
    libinput Send Events Mode Enabled Default (294):    0, 0
    Device Node (295):  "/dev/input/event10"
    Device Product ID (296):    1739, 30383
    libinput Drag Lock Buttons (325):   <no items>
    libinput Horizontal Scroll Enabled (326):   1
1
  • Yes it works now thanks a lot ! Sep 18, 2021 at 14:04

2 Answers 2

4

Run xinput and note down the touch- or trackpad ID.

  • Execute

    xinput set-prop <id> 'libinput Disable While Typing Enabled' 0
    
  • Or, as you did, list its properties with xinput list-props <id>, note down the property number of the "Disable While Typing Enabled" line (in your case 335) and execute

    xinput set-prop <id> <property> 0
    
3

Alternative to the above solution, which did not work for me.

After installing gnome-tweaks I was able to use the GUI to manually alter the setting Disable while typing.

  1. Install gnome-tweaks with:
    sudo apt install gnome-tweaks

  2. After installing, open gnome-tweaks by typing in your terminal:
    gnome-tweaks

  3. Navigate to Keyboard and Mouse Tab.

  4. Under Touchpad, unselect option Disable While Typing.

Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .