2

I have been having WiFi trouble for months now, and I've tried all manner of solutions with no change.

Hardware: Mid 2012 MacBook Pro unibody, 16gb RAM and 500gb Samsung SSD

OS: Kali Linux 2021.2 with weekly updates to all software. Running Live with Persistence from a USB drive.

Driver: Broadcom BCM 4331

Problem: Linux will connect to my iPhone hotspot with no problems and no connection lag, but when connecting to my university's WiFi or home WiFi, it either will not make the connection at all, or establish a connection for about half an hour, then stop working. Webpages pull up a "connection timed out" or "could not reach the server" errors. Currently I have a decent connection to my university's WiFi, but about a half-hour prior, I could not connect at all.

Attempted:

  • uninstalling and reinstalling NetworkManager
  • Manually filling out WiFi router details in the nm-applet
  • Uninstalling and reinstalling OS
  • Adding wifi.scan-rand-mac-address=no to /etc/NetworkManager/NetworkManager.conf
  • addressing router directly, both with the default address 192.168.1.1 and the gateway address that appears after running route in the terminal -Edited /etc/network/interfaces and added wlan0
  • Numerous NetworkManager restarts.
  • when a connection is established, even if no webpages are loading, the command ping still shows that there is a connection with no packet loss
  • set DNS servers to 8.8.8.8 and 8.8.4.4 in the IPv4 settings in NetworkManager
  • module bcma is listed when running command sudo lsmod, used by b43 which is my driver
  • added deb http://http.deb/debian.org/debian bullseye-backports main contrib non-free and deb http://us.debian.org/debian bullseye main non-free to /etc/apt/sources.list, updated and upgraded with these sources
  • manually installed linux-headers-amd64, linux-image-amd64, and linux-kbuild-5.10
  • ran apt install broadcom-sta-dkms followed by modprobe-r b43 b43legacy ssb brcmsmac bcma and modprobe wl, after reboot, WiFi seems to be working again

Various other attempts were made to fix the problem but I can't remember what all I tried. At the moment, all edits to /etc/network and /etc/NetworkManager files have been removed, all NetworkManager settings are the default.

1 Answer 1

2

Solved my own problem! The solution was to:

  1. Add
      deb http://deb.debian.org/debian bullseye-backports main contrib non-free
      
    and
      deb http://deb.debian.org/debian bullseye main non-free
      
    to /etc/apt/sources.list.d/deb.list.
  2. Run apt update and apt upgrade as well as apt dist-upgrade to add all the new dependencies and packages from the sources you added above.
  3. Manually install linux-headers-amd.64, linux-image-amd64, and linux-kbuild-5.10, all of which were listed as "not upgraded" after completing the update & upgrade.
  4. Install broadcom-sta-dkms.
  5. Run modprobe -r b43 b43legacy ssb brcmsmac bcma to remove all of these driver files and packages.
  6. Run modprobe wl to activate only the wl driver.

After this, NetworkManager wouldn't find wireless connections at all, but after a reboot, I discovered the problem had disappeared and I'm now on day three of stable WiFi.

** Edited to reflect recommendations from the Kali Linux documentation, which discourages adding additional repositories to the /etc/apt/sources.list file. The two new repositories bullseye backports and bullseye main have been moved to a new file called deb.list (https://www.kali.org/docs/general-use/kali-linux-sources-list-repositories/#non-kali-repositories).

[Note from third-party editor "infamous_spy"]  *** Edited the sources listed in deb.list since they were the ones that worked for me. By the way, the solution works. Wlan connection is faster and stable.

2
  • 1
    Hello. You will probably want to review your solution as it is now explicitly against the Kali Linux documentation, which discourages adding other distribution repositories to prevent breaking your system in the long run: kali.org/docs/general-use/kali-linux-sources-list-repositories/… Commented Sep 19, 2021 at 13:18
  • this works as of Nov'22 on a freshly installed Kali on a 2013 MBP that had the same problem, connection kind of working but unusable, very instable. Thanks for documenting your findings!
    – palako
    Commented Nov 11, 2022 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .