1

My Dell Inspiron 5405 (Ryzen 4500U CPU, integrated Radeon graphics) runs Pop OS 21.04 (kernel version 3.11). I have installed Powertop, auto-cpufreq, and kept my firmware and OS up to date.

A random number of minutes after my laptop suspends, the fan starts spinning at full speed and it gets really hot. I am unable to wake my laptop up and have to force a shutdown and reboot via holding the power button. A lot of battery is drained when this issue occurs (I once left it suspended for a couple hours on battery power, and it reduced from 100% to 43%).

This issue occurs all the time with a USB device connected to one of my ports, and randomly without. It occurs regardless if my laptop is plugged in, if lid is closed or open, or if suspend was triggered automatically or manually. In the event the issue does not occur and suspend works normally, my laptop remains cool, the fan does not spin, and I am able to wake my laptop normally.

At first, I thought it was due to my laptop's sleep mode being set to s2idle instead of S3 'deep' sleep. However, running cat /sys/power/mem_sleep reports back [s2idle] instead of the expected [s2idle] deep as seen in online forum solutions. This meant my laptop has only one sleep mode (ie. s2idle). My BIOS is at its latest version and it does not have settings to change sleep modes. I have tried various methods to force deep sleep, including via GRUB and systemd modifications, to no avail.

Using journalctl, I decided to record my log file after two occasions, one being a successful 'normal' suspend, and the other being an unsuccessful 'failed' suspend as described above. For both tests, I did not leave any window or app open or running, and allowed my laptop to suspend automatically after 15 minutes.

For the normal successful suspend, I get the following, where 18:36 is the time I closed my lid and allowed my laptop to enter suspend automatically (automatic suspend set to 15 minutes), and 19:10 is the time I opened my lid and woke my laptop with a touchpad click: https://pastebin.com/ZMzesJvj

For the unsuccessful 'bad' suspend, I get the following, where 17:48 is the time I closed my lid and allowed my laptop to suspend automatically. I was unable to wake my laptop after that. I forced shutdown and rebooted my laptop (holding the power button) at a certain time that I do not remember, but it is definitely on or after 18:24: https://pastebin.com/sMwvpGKX

It seems that for a bad suspend, my laptop 'reboots' itself during the suspend, runs a lot of tasks that raises my CPU workload and causes my fans to spin like crazy and release a lot of heat, and renders it unable to be awoken.

I really like this OS and it is perfect aside from this really annoying issue that heavily hinders my laptop's battery life, and also this OS is quite battery-intensive on my laptop in general. Any help or fixes is appreciated.

1

1 Answer 1

0

Please try installing Linux kernel 5.14 which has seen a ton of improvements in the code specific to AMD iGPUs.

If that still doesn't help try updating your BIOS. If that still doesn't help file a bug report.

6
  • Thanks for the correction. I installed 5.14.4, but I have trouble with linux-headers-5.14.4-051404-generic. It cannot be installed as I need the dependency libc6 (>= 2.34), and I still have 2.33-0ubuntu5. When I try to install libc6_2.34-0ubuntu2_amd64.deb downloaded from archive.ubuntu.com/ubuntu/pool/main/g/glibc , I am told that 2.34 will "break locales", and it cannot be installed.
    – botsunny
    Sep 15, 2021 at 13:46
  • You don't necessarily need the headers package for the new kernel. You may as well leave the old one installed. Sep 15, 2021 at 14:04
  • I see. Version 5.14.4 seems to have made things worse though. I am now unable to wake my laptop every time I suspend. It will either show my frozen lock screen, a blank white screen, or just black, when I press my touchpad or keyboard. Is it possible to downgrade to version 5.14.0 using the Ubuntu Mainline Kernel Installer? I just simply click to install the one I want to downgrade to? Asking this before trying it out myself as I fear something bad may happen. I'm still new to Linux systems and the kernel in general.
    – botsunny
    Sep 15, 2021 at 14:22
  • With Linux you can have as many kernels installed as you'd like. Looks like you really want to file a bug report here: gitlab.freedesktop.org/drm/amd/-/issues Actually they already have quite a large number of reports related to software suspend/resume: gitlab.freedesktop.org/drm/amd/-/… Sep 15, 2021 at 14:51
  • I see. I have decided to just set up hibernation instead, until the bug is fixed. Thanks for your help!
    – botsunny
    Sep 16, 2021 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.