0

On one of my Debian 10/KDE machines, but not another with almost the same setup, the sound went missing during or shortly before upgrading to Debian 11. It disappeared in the tray bar and the machine doesn't output any sound despite of pulseaudio running since I ran sudo apt-get dist-upgrade before changing the sources.list entries from "buster" to "bullseye". I have since completed the upgrade but the audio still isn't back. I even reinstalled pulseaudio and pulseaudio-utils (the latter was shown as manually installed). It's not just the audio output isn't working: entering "audio" in the KDE tray search doesn't show the audio settings and in the right traybar the loudspeaker icon is missing.

The audio went missing once before but it worked again after upgrading a few packages. Back then I thought the cause may have been mismatching dependencies due to Basil Gello's Kodi19 repository which I now (after the problem occurred) have removed from the packages sources...I also reinstalled Kodi afterwards.

Maybe the problem is caused by some problematic locally installed package. apt list --installed | grep installed,local is now listing many packages which surprises me. If this may be the cause: is there a way to try to reinstall all of these packages from the official repos (and maybe also compare hashsums to see if these are identical)?

1 Answer 1

1

I found that plasma-pa is the package that is used for audio control KDE Plasma and found it was not installed on the other machine even though it must have been installed prior to upgrading.

It was solved by sudo apt-get install plasma-pa.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.