1

This question is related to Unable to configure font in XTerm, however, I have not been able to get it to work.

I want to be able to have the Huge font enabled by default for me when I start xterm.

I have the following in my .Xresources:

XTerm*renderFont: true
XTerm*faceName: MiscFixed:style=Huge
XTerm*faceSize: 10
XTerm*faceLabel: Huge

followed by xrdb -merge .Xresources but the Huge VT Option does not get invoked and I am still at the Default setting.

This does not do anything to get the xterm have "Huge" fonts. I also tried a bunch of things such as XTerm*VTFonts: Huge but to no avail. How do I go about doing this?

2
  • xterm won't handle MiscFixed:style=Huge; it expects a family name with an optional size (whether fontconfig does is a different matter). There's no faceLabel resource, either. Sep 13, 2021 at 19:01
  • The question may be about this font. Sep 13, 2021 at 22:30

1 Answer 1

1

If you want the huge font when running xterm interactively, you can use an alias. I like the fonts selected from the FreeType library, -fa default and to control the size with -fs <size> for example

xterm -fa default -fs 16

and make an alias with it

alias xterm='xterm -fa default -fs 16'

If you like it, you can edit your configuration file for the shell, for bash ~/.bashrc, and add the alias near the other aliases and save the file. Also for bash, run

source ~/.bashrc

to activate it in the current window or screen. Whenever you start a new shell, the alias will be available, type

xterm

and you get the font and size defined by the alias.

Update by OP:

The above is a great solution, and what I used to do in the past. However, following the above, I was able to go back and look at the manual. I searched -fs there and got the idea to the following Setting:

XTerm*renderFont: true
XTerm*faceName: MiscFixed
XTerm*faceSize: 16

in my .Xresources does the needful and is an alternative way, that is more in line with what I was looking for as an answer to my question.

2
  • Thanks to @sudodus, I have found my answer and edited the above answer. I intend accepting it once it is approved. Thanks again! Sep 14, 2021 at 5:02
  • You are welcome @user3236841 :-) I'm glad that I could help you a bit on the way to find a good solution.
    – sudodus
    Sep 15, 2021 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.