0

Security type WPA2 Personal. Modem / Router is CenturyLink C4000XG. I had Ubuntu installed previously, same issue. I would prefer to get this chip working rather than use a USB wifi adapter (I have one but had no luck with it either, I think the issue is something else, possibly because this modem is rarely used for Linux because CenturyLink is like "lol linux wat").

4 machines (mac, mac, windows, android) can connect to this wifi with no issues. I can even take one of the USB adapters and plug it in to the windows machine and use the USB to connect to the wifi. The linux machine is currently connected to the internet via a CAT5 cable that is running across my floor to the garage. Sticking with the CAT5 means crawling around in the crawlspace and drilling through concrete. So I'd really prefer to get the wireless working.

Following this guide: https://linuxcommando.blogspot.com/2013/10/how-to-connect-to-wpawpa2-wifi-network.html

$ uname -a
Linux media-cube 5.4.0-81-generic #91-Ubuntu SMP Thu Jul 15 19:09:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/lsb-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=20.2
DISTRIB_CODENAME=uma
DISTRIB_DESCRIPTION="Linux Mint 20.2 Uma"

$ iw dev
phy#0
  ...
    Interface wlp3s0
        ifindex 3
        wdev 0x1
        addr 34:e6:ad:da:28:43
    ...

$ ip link show wlp3s0
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DORMANT group default qlen 1000
    link/ether 34:e6:ad:da:28:43 brd ff:ff:ff:ff:ff:ff

$ sudo ip link set wlp3s0 up # bring it up just to make sure

$ iw wlp3s0 link
Not connected.

$ iwlist scan
...
wlp3s0    No scan results

$ sudo iw wlp3s0 scan
$ # THIS SEEMS LIKE A PROBLEM

# edit: added nmcli

$ nmcli dev status
DEVICE          TYPE      STATE         CONNECTION
enp2s0          ethernet  connected     Wired connection 1
wlp3s0          wifi      disconnected  --
p2p-dev-wlp3s0  wifi-p2p  disconnected  --
lo              loopback  unmanaged     --
$ nmcli radio wifi
enabled
$ nmcli dev wifi list
IN-USE  BSSID  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY
$

This is already getting long, so the rest of my troubleshooting is in this pastebin: https://pastebin.com/LphnG3gN

What next? Am I missing something?

e: /etc/network/interfaces says source-directory /etc/network/interfaces.d and /etc/network/interfaces.d is empty

3
  • If you are following that 7-year-old guide, have you done something to NetworkManager? It will run wpa_supplicant for you., if you use any of NetworkManager's configuration interfaces... but if you are trying to run a stand-alone wpa_supplicant and haven't disabled NetworkManager, it might be interfering with the wireless configuration.
    – telcoM
    Sep 10 '21 at 2:54
  • I've done nothing to network manager. Here's the output of nmcli dev wifi list -- pretty much nothing: IN-USE BSSID SSID MODE CHAN RATE SIGNAL BARS SECURITY (no further lines) -- that article was the first one I found after searching for 'connect to wpa2 linux'
    – jcollum
    Sep 10 '21 at 2:57
  • I added the nmcli output
    – jcollum
    Sep 10 '21 at 3:00
0

You have not told NetworkManager to keep its electronic fingers off wlp3s0 (= nmcli dev status doesn't say unmanaged for it), and you have not told NetworkManager what you wish to do with the WiFi adapter, so it assumes you wish to keep it disabled in a power-saving state, and takes steps to make just that happen.

Undo anything you may have done to run wpa_supplicant manually, and let NetworkManager handle it.

For example, if the name of your wireless network is my_wifi and the network password is <password>, just run this command:

nmcli d wifi connect my_wifi password '<password>'
6
  • Tried that: Error: No network with SSID 'JDub' found. -- it's not seeing the network. wlp3s0 shows UP state with ip link so I don't understand why you think it's down. All I did with wpa_supplicant was create a conf file, hard to see how that could be messing things up. I'll delete that file and try again but I doubt it will matter.
    – jcollum
    Sep 10 '21 at 3:40
  • deleted supplicant conf file, tried nmcli connection again, same result
    – jcollum
    Sep 10 '21 at 3:41
  • also tried sudo nmcli dev set wlp3s0 managed yes then nmcli to connect, no change
    – jcollum
    Sep 10 '21 at 3:43
  • Yes, your ip link show wlp3s0 shows UP but also has state DOWN mode DORMANT later on the same line.
    – telcoM
    Sep 10 '21 at 6:37
  • ok how do I fix that? tried ip link set wlp3s0 up, output in the post
    – jcollum
    Sep 10 '21 at 15:33
0

Well this turned out to be a hardware problem. There are two antennas in the machine that are supposed to be connected to very tiny plugs in the machine, on the mini wireless card. I plugged them in and the wireless started working, poorly.

If anyone has a suggestion for how I could have detected that in the logs that would be very helpful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.