I'm trying to boot CentOs already installed on an appliance. This appliance has only two input connectors:

  • 1 USB port, where I plugged in a USB hub, to which I connected a keyboard
  • 1 Male 9 Pin Serial port / RS232

It also has 2 Gigabit Ethernet ports, one of which is used for remote administration with Intel BMC and Intel SOL (Serial-Over-LAN)

I'm connected to the server via the Intel SOL.

Now the problem: when I boot the server, I successfully reach the Grub loader and I can select the entries, but after that, the output shows the character, and nothing more happens, whichever the entry I select.

I tried to boot from a live Centos image (using a USB Pendrive connected to the USB hub) but also, in this case, I can see the Grub loader, I can select the desired entry, but then it stuck with character.

I also tried to:

  • disable the quiet mode from the kernel flags
  • add init=/bin/bash to the kernel lines
  • add console=tty0 console=ttyS0 console=tty1 console=ttyS1 to the kernel lines
  • in Grub Rescue mode, chain load and boot the grubx64.efi from the OS already installed and from the USB Pendrive

I'm honestly out of options now, any suggestion would be greatly appreciated.


1 Answer 1


Adding console=ttyS0,115200 console=ttyS1,115200 to the linux command and dropping rhgb solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .