The above behavior only occurs when cold starting the device. Entering and leaving BIOS already circumvents the problem. But so does pressing ctrl+alt+del when the grub menu is shown. Any other approach - like multiple combinations of options in BIOS - did not work for me.

Update: The device crashed when on duty and rebooted constantly with an uptime between 10 minutes and 3 hours. It's currently under investigation again, but seems stable without network/load. Memtest passes 4 rounds error-free.

  • I'm having the same issue. Did you find out anything else?
    – RandomAndy
    Jan 18, 2022 at 16:28
  • @RandomAndy: Since my workaround seems tho have "solved" my problem I was not in need for further research. But I plan to do a full re-powering- test in the next weeks, i.e., simulate a power loss on the rack with switches and routers affected. If that does not work as expected I will (have to) either do more research or replace the device in the rack and use the N4020 for some other duties. I'll post an update if I find something new.
    – RuDevel
    Jan 21, 2022 at 17:17

2 Answers 2


I experimented a bit and "solved" (circumvented) this by first "booting" into a reboot and starting the linux kernel afterwards:




exec tail -n +3 $0
   echo "Provoking a reboot and then booting the FIRST remaining option (#1)..."
   echo "This circumvents the soft locks errors/crash on COLD (power on) boot!"
   set saved_entry=1
   save_env saved_entry
   sleep 5 #remove to save 5 more seconds on boot

root:crontab -e

@reboot /usr/bin/grub-set-default 0 #set the default back to MINISFORUM BOOTFIX

This way also the Power On BIOS option works fine, so the device flawlessly boots into Linux when (re)powered.

I'm still happy for real Solutions to this problem. My guess would be somewhere between a thermal issue or some initialization problems with the eMMC.


soft lockup is a Linux kernel bug, when some task can cause threads to loop and the kernel does not release activity to other processes. updating the kernel seems like a only workaround.


$ sudo apt-get upgrade


$ sudo apt upgrade

Install kernel updates on a Ubuntu LTS server

Type the following apt-get command:

$ sudo apt-get dist-upgrade

If a new kernel installed, reboot the Linux server:

$ sudo reboot

check if it still occurs


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .