0

I am running Arch Linux and am using iwctl to connect to the WI-FI. I have tried to connect to a network that is using 8021x security and iwctl comes up with the error message “Not configured”. How do I configure iwd to work with this network?

Edit: The network also requires a username to login not just a password.

0
1

For 802.1x, you need wpa_supplicant. To my knowledge you cannot configure this with iwctl.

The documentation for wpa_supplicant on Arch Linux is here, and for the configuration of 802.1x it refers to man wpa_supplicant.conf

3
  • Sorry for late reply, I was able to test it today (working with psk network) and I got an error: SME: Deauth request to the driver failed``CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="CUS" auth_failures=5 duration=10 reason=CONN_FAILED . My wpa_supplicant.conf is: ctrl_interface=/run/wpa_supplicant update_config=1 p2p_disabled=1 network={ ssid="CUS" key_mgmt=IEEE8021X eap=PEAP identity="username" password="password" phase2="autheap=MSCHAPV2" } Starting with: sudo wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf Any suggestions? Thanks. Sep 13 at 15:45
  • It's extremely hard to do remote debugging, in particular without seeing all the logs etc. However, I did have trouble with wpa_supplicant in the past, where I got random Deauth messages, and the reason was a driver issue, and after updating the kernel it went away. This may or may not be the problem in your case.
    – dirkt
    Sep 13 at 15:58
  • I have updated to the latest kernel and have tried specifying drivers using the -D option for wpa_supplicant to no success. Sep 15 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.