After I select left/SMB link... and enter the urn and user name and password I see this error message

Cannot chdir to "/smb://host.network/share"

I've tried different variant of the urn

Where the first two are documented in the F1 screen. Could this related to a version restriction on the server side? Needless to say \\host.network\share works like a breeze in Microsoft Window's File Explorer. Also smbclient //host.network/share gets a connection.

$ mc --version
GNU Midnight Commander 4.8.26
Built with GLib 2.68.0
Built with S-Lang 2.3.2 with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish, smbfs
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

1 Answer 1


Midnight Commander's SMB implementation uses a very old version of the CIFS protocol which Samba disables by default.

You could fix it by adding:

    server min protocol = CORE
    client min protocol = CORE

to the [global] section of the /etc/samba/smb.conf file.

This makes Samba enable a very insecure version of the CIFS protocol which you should never use unless you have your own private LAN with only trusted devices.

A pertinent bug report: https://midnight-commander.org/ticket/1

  • Thanks. I thought as much. I was able to achieve my goal with smbclient. Do you happen to have insight on when the issue will be alleviated in MC?
    – theking2
    Sep 8, 2021 at 16:43
  • 2
    As soon as someone steps up and writes the necessary code. :-) Its core maintainers are not interested but they are surely considering removing the old code for the sake of security. Sep 8, 2021 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .