I have been using Arch for quite some time now and the microphone used to work perfectly. But yesterday, I installed pavucontrol and suddenly the mic stopped working, i.e. no audio is picked up even though the mic is recognised by PulseAudio.
I have ALSA installed as well.
Here are some relevant info:

arecord -l                  
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC236 Analog [ALC236 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Any help is appreciated :)
Edit: Sorry if it wasn't clear enough. PulseAudio was already installed a long time ago, the output and input worked perfectly. But yesterday, when I installed pavucontrol, the mic stopped recording audio (I found out from a call) but it is recognised as an input device.
Here's a screenshot of input devices from pavucontrol: pavucontrol

  • Please edit question and explain if you only installed pavucontrol or Pulseaudio as well, how you found out your microphone is not working, and what pavucontrol shows when you try to record from the microphone. (Guess: it picks the wrong source).
    – dirkt
    Sep 7, 2021 at 7:45
  • idk if that's relevant to my problem but I can't record using arecord, I always get the error: ALSA lib pcm_dsnoop.c:600:(snd_pcm_dsnoop_open) unable to open slave even though there is no other application using the mic
    – yH20
    Sep 7, 2021 at 10:08

1 Answer 1


Partial answer, based on the information in the question so far:

If you have Pulseaudio running, Pulseaudio starts using all the ALSA hw devices, and you cannot use arecord directly on an ALSA device anymore. If you not only installed pavucontrol, but all of Pulseaudio, that would explain why it suddenly stopped working.

So use parecord instead of arecord, or use arecord on the pulse ALSA compatibility device instead of dsnoop or whatever you have in your ALSA configuration (I recommend changing your ALSA configuration to make pulse the default device), and use pavucontrol to ensure arecord points at the right source.

  • 1
    thank you very much! parecord worked perfectly. I also found out that pulseaudio-alsa package was not installed, so I installed it and the mic works perfectly. thanks again :)
    – yH20
    Sep 7, 2021 at 11:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .