0

I have (LMDE2) debian 8 (jessie) and want to install network printer. My printer is supported in hplip v3.18.5 but only v3.14.6 is available, therefore I need to compile hplip from source.

There is list of Dependency Packages which I am looking for. Can someone translate this into valid package names for (jessie)?

mint@debian ~ $ uname -a
Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1 (2016-12-30) x86_64 GNU/Linux
mint@debian ~ $ sudo apt install cupsys cupsys-client cupsddk cupsddk-drivers libcupsys2-dev cupsys-bsd libcupsimage2-dev libdbus-1-dev gcc g++ gs-esp libssl-dev libjpeg-dev libsnmp9-dev libc6 libtool libusb-1.0-0-dev make wget python-imaging policykit python-qt4 python-qt4-dbus python-dbus python-gobject python-dev python-notify python python-reportlab sane libsane-dev sane-utils xsane
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libsnmp-dev' instead of 'libsnmp9-dev'
Package cupsys-client is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package cupsddk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package cupsys-bsd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package cupsys
E: Package 'cupsys-client' has no installation candidate
E: Package 'cupsddk' has no installation candidate
E: Unable to locate package cupsddk-drivers
E: Unable to locate package libcupsys2-dev
E: Package 'cupsys-bsd' has no installation candidate
E: Unable to locate package gs-esp
E: Unable to locate package policykit
mint@debian ~ $ 
3
  • 1
    "cups~~client, cups~~bsd etc." got new names. But hplip-3.18.5 compiles OK with old packages, e.g. # apt-get install libjpeg-dev libcupsppdc1-dev libcupsmime1-dev libcupsimage2-dev libtiff5-dev libcupsfilters-dev libcups2-dev libgutenprintui2-dev libdbus-1-dev libsane-dev libusb-dev libusb-1.0-0-dev libsnmp-dev libssl-dev libudev-dev Commented Sep 5, 2021 at 16:20
  • 1
    thx got printer working. for the sake what would be new names for cupsys cupsys-client cupsddk cupsddk-drivers libcupsys2-dev cupsys-bsd? figured out g̶s̶-e̶s̶p̶ = ghostscript-x, p̶o̶l̶i̶c̶y̶k̶i̶t̶ = policykit-1
    – alecxs
    Commented Sep 5, 2021 at 17:45
  • You are listing the new cups packages. Old names, see "hplip-3.18.5-deps.txt" from today drive.google.com/file/d/1HgKYodGc5pRWCzBccw23tir2tf3BmRCx/… Commented Sep 5, 2021 at 18:09

1 Answer 1

-1

Upgrade or install to LMDE4.

LMDE2 is not supported any more.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .