0

I'm new to Linux but I'm going to try my best to describe the problem, please bare with me, if you need more information tell me what I can do to provide more information and I'll get it for you.

After booting up my system and opening Steam the entire OS locked up, I could move the mouse but nothing else (including alt+f2) worked. I force rebooted the system and after the seeing the Systemd boot menu I saw a flash of gray from the Gnome login screen right before being dumped back to this screen:

enter image description here

Pressing ^d just prints the "You are in emergency mode" speal again. And writing exit results with Failed to starte default target: Transaction for graphical.target /start is destructive

I have three drives in my system, the first is an NVME with Windows installed on it (Fastboot has been disabled), the second is a Seagate HDD formatted as NTFS that the Windows and Linux (PopOS) systems share (Windows "automounts" drives on its own, I set the Seagate to auto-mount on boot in Pop via the Gnome disk manager a while back, not recently). And the third drive is a Samsung Evo Sata SSD that Pop boots off of.

Booting between the current kernel and the old kernel via the systemd boot menu makes no difference. I can boot into Windows which should rule out hardware failure everywhere except the Samsung Evo (Which is less than a year old).

Running cat /etc/fstab from within emergency/maintenance mode provides this:

enter image description here

This looks okay to me, but I'm not very familiar with fstab.

Booting into PopOS's recovery partition (much like plugging in a flash drive and booting a live OS) and then running fdisk -l yields this:

enter image description here

The Seagate drive appears to be mounted as sda

enter image description here

The Samsung that Pop is booting off of appears to be mounted as sdb

enter image description here

fsck appears to believe that the Samsung boot drive is fine.

If anyone has any idea what's going on here I could really appreciate the help. If worst comes for worse, would refreshing the OS from the recovery partition fix this issue?

3
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – terdon
    Commented Sep 7, 2021 at 11:07
  • You showed this as label. Was it mounting automatically using label before you added fstab entry? LABEL="Seagate 2T Secondary" and then since in quotes it will work. I stopped using spaces years ago when I first started to use Ubuntu, but still had XP as dual boot. I changed to CamelCase, under_score or justaname.
    – oldfred
    Commented Sep 12, 2021 at 22:12
  • @oldfred Before it was just mounting off of /dev/sda2, no label, no UUID as thats what Gnome Disk Utils created. While I'm now using the UUID to mount the drive as it seems to be better practice. For some reason changing the mount location from /home/pierce/Seagate 2T Secondary to /home/pierce/Seagate-2T-Secondary is what fixed the problem.
    – Jhon Piper
    Commented Sep 12, 2021 at 22:57

1 Answer 1

2

I had a similar problem, below is my current lsblk, i solved it by removing an fstab entry

sdb 8:16 0 1.8T 0 disk
├─sdb1 8:17 0 16M 0 part
└─sdb2 8:18 0 1.8T 0 part /mnt/xxx

I had an sdb3 partition which had a fstab entry, I deleted the sdb3 partition without removing the fstab entry, after which i got booted into emergency mode.

fixed it by commenting out the relevant fstab entry in /etc/fstab, you could also delete it

#PARTUUID=XXXxX-xxxx-xxxx-xxxx-xxxxxxxxxxxx /mnt/winc ntfs defaults 0 0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .