1

I added and updated Debian's experimental distribution to my source list which should contain neovim 0.5.0-1.

deb http://deb.debian.org/debian experimental main contrib non-free

When I run apt-cache policy neovim I can see only 0.4.4-1

  Installed: (none)
  Candidate: 0.4.4-1
  Version table:
     0.4.4-1 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages

If I run apt-cache policy nano I can see the latest version from the experimental.

apt-cache policy nano
nano:
  Installed: 5.4-2
  Candidate: 5.4-2
  Version table:
     5.8-1 1
          1 http://deb.debian.org/debian experimental/main amd64 Packages
 *** 5.4-2 500
        500 http://deb.debian.org/debian bullseye/main amd64 Packages
        100 /var/lib/dpkg/status

1 Answer 1

1

If you scroll down to the bottom of the neovim package page for experimental, you can see that it’s not available on amd64. That’s because it fails to build there (the build timed out).

A useful tool to figure this out locally is rmadison, in the devscripts package:

$ rmadison neovim
...
neovim     | 0.5.0-1        | experimental            | source, i386, ppc64el
neovim     | 0.5.0-1        | experimental-debug      | source

You could add the i386 architecture with dpkg --add-architecture i386, and install that version of the package; or wait for the build to be fixed.

1
  • Thank you @Stephen. You saved my day!
    – Lajos
    Commented Sep 3, 2021 at 12:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .