2
[  OK  ] Reached target Final Step
[  OK  ] Finished Power-Off.
[  OK  ] Reached target Power-Off.
[27022.555948] sd-umoun[21227]: Failed to unmount /oldroot: device or resource busy
[27022.560980] sd-umoun[21228]: Failed to unmount /oldroot/dev/pts: Device or resource busy
[27022.563273] sd-umoun[21229]: Failed to unmount /oldroot/dev: Device or resource busy
[27023.565921] shutdown[1]: Failed to finalize  file systems, ignoring
[27023.781186] hub 6-0:1.0: hub_ext_port_status failed (err = -110)
[27024.808694] Kernel panic - not syncing: Timeout: not all CPUs entered broadcast exception handler
_
 ] Stopped remount Root and Kernel File Systems.
 ] Stopped Monitoring of LVM2 mirror, snapshots etc. using dmeventd or progress polling
 ] Reached target Shutdown.
   Starting Shuts down the "live" preinstalled system cleanly...
 ] Finished Shuts down the "live" preinstalled system cleanly.
 ] Reached target Final Step
 ] Finished Power-Off.
 ] Reached target Power-Off.
1.287672] sd-umoun[3729]: Failed to unmount /oldroot: device or resource busy
1.289859] sd-umoun[3730]: Failed to unmount /oldroot/dev/pts: Device or resource busy
1.292206] sd-umoun[3731]: Failed to unmount /oldroot/dev: Device or resource busy
1.296931] shutdown[1]: Failed to finalize  file systems, ignoring
2.635950] hub 6-0:1.0: hub_ext_port_status failed (err = -110)

I recently installed Linux Mint on a 2008 MacBook 4,1. It mostly works well but the shutdown process sometimes gets stuck right at the end. I have searched around for a solution and have so far increased the default shutdown limit from 10s to 100s and also blacklisted the USB2 drivers (USB ports still work fine using the USB3 drivers). The problem happens about half the time. I dual boot with Mac OS X 10.7.5 and use ReFind as a boot manager although I can also boot from Grub. From neofetch:

OS: Linux Mint 20.2 x86_64
Host: MacBook4,1 1.0
Kernel: 5.4.0-81-generic
Packages: 2371 (dpkg), 5 (flatpak)
Shell: bash 5.0.17
Resolution: 1280x800
DE: Xfce
WM: Xfwm4
WM Theme: Mint-Y
Theme: Mint-Y [GTK2/3]
Icons: Mint-Y [GTK2/3]
Terminal: xfce4-terminal
Terminal Font: Monospace 12
CPU: Intel Core 2 Duo T8300 (2) @ 2.4 GHz
GPU: Intel Mobile GM965/GL960
Memory: 1431MiB / 3916MiB

I took a photo of the screen after it froze which might show what I need to do to fix it. I hope I posted in the right section. Thanks in advance for any tips.

If not a fix for this particular problem, are there any configuration changes that would force the MacBook to shut down once the "Reached target power off" is posted. The second picture shows a kernel panic left as the last message before it froze.

1
+100

Please try setting intel_idle.max_cstate=1 in your grub config. Then boot with grub and see if the issue still persists.

5
  • I put this into the /etc/default/grub file and then updated grub but it gave an error message. intel_idle.max_cstate=1 not found. Sep 13 at 8:20
  • Put it inside GRUB_CMDLINE_LINUX_DEFAULT
    – Alex
    Sep 13 at 14:57
  • That was exactly what I was looking for, thank you. Sep 14 at 13:13
  • Oops, I was premature, it didn't completely fix it. Are there any other changes I could make? Sep 15 at 17:22
  • You could completely disable cstates with the same parameter, but with the value of 0
    – Alex
    Sep 15 at 18:31
0

You can try to do this

sudo nano /etc/mkinitcpio.conf

change:
HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck"
to:
HOOKS="base udev autodetect modconf block keyboard keymap filesystems fsck shutdown"

sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg

sudo systemctl restart systemd-coredump.socket
sudo systemctl reset-failed

Some users reported that it is a nvidia driver issue and they fixed it by removing the nvdia module in /etc/mkinitcpio.conf

Link to the bug report

3
  • When I use [[sudo nano /etc/mkinitcpio.conf]] I get a blank file with nothing to edit. Sep 8 at 9:47
  • Sorry, my bad. Configuration: /etc/initramfs/initramfs.conf Mind that ... /etc/initramfs/conf.d/ can be used for configuration files and /etc/initramfs/conf-hooks.d/ for adding hooks. To rebuild you can use ... update-initramfs -u
    – meteora797
    Sep 8 at 14:52
  • Thank you for the correction, I tried that too but still no config file in Mint 20.02. Sep 13 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.